Error: VirtualBox Linux kernel driver is either not loaded or not set up correctly

I had virtualbox running, but after a recent update it now has a problem I am unable to figure out. When attempting to start a virtual machine, I get the error:

The VirtualBox Linux kernel driver is either not loaded or not set up correctly.

I believe this is because the kernel was updated, but the virtualbox driver package is not found. After the system update and a reboot, no modules are loaded, so virtualbox has an issue. I ran mhwd-kernel -li and it says:

Currently running: 5.9.16-1-MANJARO (linux59)
The following kernels are installed in your system:
** * linux414**
** * linux59**

I can see that linux414 virtualbox host modules are installed, however I cannot seem to install the linux59 host modules. I ran sudo pacman -Syu linux59-virtualbox-host-modules and it says:

error: target not found: linux59-virtualbox-host-modules

Does anyone know why I am unable to find that package? Any help would be appreciated.


You use old, unsupported kernel – that’s why you cant install proper modules and drivers. Remove 5.9 and install one of supported kernels:

available kernels:
   * linux414
   * linux419
   * linux44
   * linux49
   * linux510
   * linux513
   * linux514
   * linux515
   * linux516
   * linux54
   * linux510-rt
   * linux515-rt
1 Like

Thanks for your response. I am not sure how I ended up on that kernel. I have updated to the current recommended long term support kernel and now all is good again.

Thanks again

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.