Error: UUID not found. Skipping fsck

I’ve dual installed Manjaro with Windows 10 three months, but I’ve been more or less exclusively using Manjaro since then.
Last night, I couldn’t shut down (nothing happened, and I also tried hibernate and suspend). Therefore, I pressed the power button until it turned off. This is the first time this happened.
After I started the computer in the morning, I couldn’t get to the boot loader and it tried to boot directly into Windows where it failed with a blue screen of death (I don’t remember the error message anymore). After a few restarts, I entered into Safe Mode and afterwards Windows worked, but Manjaro was gone from boot manager.
I searched around and noticed that the BIOS settings were changed, therefore I disabled secure and fast boot again. I think I still need to enable AHCI, but I don’t remember anymore how to access the advanced options in BIOS that allowed me to do this last time.
Either way, now the boot manager allows me to see Manjaro, but when it tries to boot, I get the error as in the screenshot:

ERROR: resume: hibernation device 'UUID=fdb5d783-8590-4350-8d26-0ae438ea868c' not found
ERROR: device 'UUID=a56b1cd3-7a8d-4297-9f0d-45097facaaf1' not found. Skipping fsck.
mount: /new_root: can't find UUID=a56b1cd3-7a8d-4297-9f0d-45097facaaf1.
You are now being dropped into an emergency shell.
sh: can't access tty: job control turned off
[rootfs ]#

I’m still new to Linux / Manjaro, but just based on searching for other, similar topics, it seems that etc/fstab is empty and I assume the UUID should be stored there?

But I don’t know how to proceed. I’ve created a live boot USB again, but don’t know what I should do with it.
If there is no easy fix for it, I don’t mind to re-install everything, but only if I can save all my files. If I could access the files from Windows and copy them, it would be enough.

If it helps, I have an Acer Swift 3.

Thank you everyone in advance and if you need any further information, please ask.

Hello, immediate update, it worked after I figured out how to enable AHCI again.
For anyone curious, by pressing CTRL S in the Main tab in BIOS.
Thank you!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.