'error: unknown filesystem' during installation

I tried to install Manjaro as operating system, I made an USB drive, but can’t boot from it. It shows the next message:

error: unknown filesystem.
Entering rescue mode…
grub rescue>

I disabled Secure Boot and Legacy, and tried to follow internet tutorials, but it didn’t help.
Any hints?

Can you provide the following information?

  • Is your computer IBM-PC compatible (x86 computer with Windows) or Mac?
  • Is your computer firmware BIOS or UEFI-CMS or UEFI (searching the respective OEM website for the computer model may give a clue)?

If it is Mac, then unfortunately this may be close to impossible to solve (as far as I know, Mac firmware is an EFI-based, neither BIOS nor UEFI).

But overall, judging from the error, it seems the USB-live wasn’t configured properly since you had entered the grub bootloader.

Its Windows, and with BIOS. How can I solve this?

Your problem seems in the live-USB.

My advice:

  • Check your ISO integrity.
  • Use Rufus on Windows to configure live-USB drive.

Check for your Manjaro ISO file integrity, it may be corrupted and thus, the live-USB drive is also corrupted.

I always use OpenSSL application provided by git installation (you can get git from the internet) to check for the SHA1 hash.

From git bash: openssl sha1 MANJARO-ISO

The SHA1 of Manjaro ISO is located in the respective download page of Manjaro.

If the SHA1 you get isn’t the same as the one from the website, that means your ISO is corrupted and you need to download it again.

I always use Rufus on Windows to make a live-USB drive. It’s the safest to use in my opinion.

If none of the above works, try enabling your Legacy (but turn off Secure Boot).

It seems your computer supports BIOS and UEFI-CSM (Legacy). So if you fail using BIOS, you can try using UEFI-CSM instead.

Thank you very much for your help, it worked.
Have a nice day!