Error: systemd-backlight

On a LENOVO Laptop I have an error message:

$ systemctl --failed
  UNIT                                            LOAD   ACTIVE SUB    DESCRIPTION                                 >
● systemd-backlight@backlight:acpi_video0.service loaded failed failed

I tried the typical recommendations with all four options


For all the options as before without any) the screen brigthness is fine and can be adjusted using FN-F5 / F6.
How to get rid of that message?

  Kernel: 5.10.41-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=3fb81935-3c2a-4b83-ae67-7b8f75e23839 rw noplymouth 
  Desktop: KDE Plasma 5.21.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: LENOVO product: 20UH001QGE v: ThinkPad T14s Gen 1 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: LENOVO model: 20UH001QGE serial: <filter> UEFI: LENOVO 
  v: R1CET60W(1.29 ) date: 11/30/2020 
  Device-1: AMD Renoir vendor: Lenovo driver: amdgpu v: kernel bus-ID: 06:00.0 
  chip-ID: 1002:1636 class-ID: 0300 
  Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo 
  bus-ID: 2-2:2 chip-ID: 13d3:5405 class-ID: fe01 serial: <filter> 
  Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: 
  loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa 
  display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 158 size: 309x173mm (12.2x6.8") 
  diag: 354mm (13.9") 
  OpenGL: renderer: AMD RENOIR (DRM 3.40.0 5.10.41-1-MANJARO LLVM 11.1.0) 
  v: 4.6 Mesa 21.1.2 direct render: Yes

Hi @MaMicha ,
I think the explanation given in the post you mentioned, the last part from @jonathon from the Manjaro Archive on GitLab , should be enough. Did you update the grub?

When you boot the system you will see a menu which lists the various boot options. The top one will say Manjaro.

When you can see the word Manjaro and it is coloured green, press the letter “e” on your keyboard once.

This will take you to a menu where you can edit the options used by the computer when it boots.

Find the line which starts with the word “linux” and use the arrow keys on your keyboard to move the cursor to the end of that line.

Once you have reached the end of that line, press the spacebar once to add a space, then type the letters


one at a time. Make sure you double-check the letters to make sure they are correct. If they are not correct, press the backspace key to remove the letters and type them again.

Once you are certain the letters have been typed correctly, press the F10 key on your keyboard once.

The operating system will now begin to boot and you can check the journal entries for see if the error persists. Apparently you’re technical enough to know how to do that bit.

If the error persists, or you find you can no longer alter the backlight by pressing the backlight keys on your keyboard, then repeat the above steps but change the letters you add to line beginning “linux” to one of the other three options:

  • acpi_backlight=vendor
  • acpi_backlight=native
  • acpi_backlight=none

If one of these options works in the way you are hoping for, you can add this option permanently so you don’t have to type it every time you boot.

One way to do this is to open a terminal application (for example, click on the Applications menu and look for a program called “Terminal”).

Once you have opened a terminal application, type these letters:

sudo nano /etc/default/grub

Make sure the letters are correct. If they are not correct, use the backspace key to delete the letters and re-type them.

Now press the Enter key on your keyboard once. You will be asked to type your password to let you edit the file.

Type your password carefully. Make sure it is correct or you will get an “access denied” error and will have to try again.

Once you have typed your password, press the Enter key once.

The “nano” text editor will load and show you the content of the /etc/default/grub file.

Use the arrow keys on your keyboard to move the entry cursor down to the line which begins GRUB_CMDLINE_LINUX_DEFAULT.

Move the cursor to the end of that line and place it between the h and the " characters so you can add letters after the word “splash”.

Press the spacebar key on your keyboard once to enter a space.

Then type the letters which match the working option you typed in when you booted the computer. As a reminder, that will be one of these options:

  • acpi_backlight=video
  • acpi_backlight=vendor
  • acpi_backlight=native
  • acpi_backlight=none

Make sure you check the letters you type to make sure they are correct. They must match the option exactly or they won’t work. Make sure the line ends with a quotation mark ".

If you make a mistake, use the Backspace key to delete the letters, then re-type them.

Once you are happy that you have typed the letters correctly press the key combination (that is, press and hold the first key, then press and release the second key, then release the first key):


This will save the file (output to a file) and exit the nano editor.

You should now be back at the black terminal window.

Type the letters for this command:

sudo update-grub

and press the Enter key on your keyboard once.

You may have to enter your password again. If so, type your password, making sure you type it correctly. If you make a mistake you will get an “access denied” error and will have to try again. Press Enter to confirm the password.

If you have entered the command correctly GRUB will add the backlight option to its menu entry and it will be present for every boot in the future.

You can verify it works by rebooting your computer. Please use the “reboot” menu item rather than holding down the power button or using the reset button on the case (if there is one).

Thanks a lot, j8a, for your very detailed description. My problem: I can’t find the starting point where to press “e”. I’m on a Laptop where I can enter the BIOS with ENTER OR F12, there the first entry is Manjaro, but pressing “e” does nothing.
May be, I have a problem in my /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor resume=UUID=338139c5-0361-42c0-9573-dbd00f711a01 udev.log_priority=3"

# If you want to enable the save default function, uncomment the following line, and set GRUB_DEFAULT to saved.

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to use basic console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE, you can see them in real GRUB with the command 'videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment to disable generation of recovery mode menu entries

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme


# Uncomment this option to enable os-prober execution in the grub-mkconfig command

This I tried with the options vendor, video, … and always fired

sudo update-grub

Solved it now this way:

  • Both lines GRUB_CMDLINE_LINUX_DEFAULT= and GRUB_CMDLINE_LINUX= only once, not multiple times as I had in the above. Multiiple options separated by BLANK.
  • All personally defined options into line GRUB_CMDLINE_LINUX_DEFAULT=
  • Check that the options have been taken: cat /proc/cmdline

This way, I added into GRUB_CMDLINE_LINUX_DEFAULT=“acpi_backlight=vendor” and the error message is gone!

1 Like

Hi @MaMicha ,
Well done, I have added video instead of vendor and the line was also gone.