ERROR: resume: hibernation device UUID not found after fresh install

Hi everybody,

I bought new asus zenbook ux425ea today and wanted to install Manjaro KDE. Installation went without errors, I repartitioned my 512GB SSD like this:
Boot FAT32 512MiB
Swap linuxswap 8GiB
Root ext4 50GiB
Home - the rest

After successful installation I rebooted and received this error:

ERROR: resume: hibernation device ‘UUID=…’ not found
mount: /new_root: can’t find ‘UUID=…’.
You are now being dropped into an emergency shell.
sh: can’t access tty; job control turned off.

I tried live booting from USB, I checked the swap UUID with ‘sudo blkid’ and then looked into /etc/fstab/ and /etc/default/grub but the UUID was correct.

Installing Ubuntu went without errors, but I dont want to be stuck with Ubuntu. Any help is very appreciated, and sorry if I misunderstood something, I am fairly new in Linux world.

I am getting the same error
and when I type bklid in the emergency shell being presented
I see that the swap partition is not showing, while when I run blkid while in the live version I get the correct id.

It seems the booting process is missing something to detect swap partition.

any idea?