Error opening SKlauncher (java)


Today iI installled the minecraft SKlauncher laucher, wich works with java.

I ran java -jar SKlauncher-3.2.8.jar in console

and it returned:

Exception in thread "main" java.awt.AWTError: Assistive Technology not found: org.GNOME.Accessibility.AtkWrapper
	at java.desktop/java.awt.Toolkit.newAWTError(
	at java.desktop/java.awt.Toolkit.fallbackToLoadClassForAT(
	at java.base/$ForEachOp$OfRef.accept(
	at java.base/$2$1.accept(
	at java.base/java.util.HashMap$KeySpliterator.forEachRemaining(
	at java.base/
	at java.base/
	at java.base/$ForEachOp.evaluateSequential(
	at java.base/$ForEachOp$OfRef.evaluateSequential(
	at java.base/
	at java.base/
	at java.desktop/java.awt.Toolkit.loadAssistiveTechnologies(
	at java.desktop/java.awt.Toolkit.getDefaultToolkit(
	at java.desktop/javax.swing.RepaintManager.<clinit>(
	at java.desktop/javax.swing.UIManager.initialize(
	at java.desktop/javax.swing.UIManager.maybeInitialize(
	at java.desktop/javax.swing.UIManager.getLookAndFeel(
	at com.formdev.flatlaf.FlatLaf.initialize(
	at java.desktop/javax.swing.UIManager.setLookAndFeel(
	at com.formdev.flatlaf.FlatLaf.setup(
	at com.formdev.flatlaf.FlatDarkLaf.setup(
	at pl.skmedix.bootstrap.ui.swing.LookAndFeel.setup(
	at pl.skmedix.bootstrap.SwingUserInterface.setLookAndFeel(
	at pl.skmedix.bootstrap.SwingUserInterface.<init>(
	at pl.skmedix.bootstrap.Bootstrap.selectUserInterface(
	at pl.skmedix.bootstrap.Bootstrap.<init>(
	at pl.skmedix.bootstrap.PreBootstrap.main(
Caused by: java.lang.ClassNotFoundException: org.GNOME.Accessibility.AtkWrapper
	at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(
	at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(
	at java.base/java.lang.ClassLoader.loadClass(
	at java.base/java.lang.Class.forName0(Native Method)
	at java.base/java.lang.Class.forName(
	at java.base/java.lang.Class.forName(
	at java.desktop/java.awt.Toolkit.fallbackToLoadClassForAT(
	... 25 more

Any ideas? Thx

(im using Gnome, as you can see in the error)


Except to mention that the AUR (which is where I believe the SKlauncher originated) is unsupported on Manjaro. You should probably contact the maintainer of the package.

You might try removing everything installed thus far, and reinstalling SKlauncher. I found the following tutorial which might be useful: How to Install Minecraft Launcher on Manjaro Linux.

Choosing a different JAVA might also be an option; for example openjdk.

Good luck.

That version is not from AUR - you used … something else.
Follow their instructions - if they give them.

The AUR has an older version - (3.2.5 if I recall correctly).

The link @soundofthunder gave mentions using AUR, but fails to mention the prerequisite for using it
git and base-devel

Here’s another:

…and another:

…and another:

…and another:

…and… OK, you get the picture.


I did not mean you - I meant the links contents.
They do not specifically remind one that base-devel is not present by default and needs to be installed for the AUR being usable.
One who follows the steps in these tutorials will likely run into issues when the prerequisites are not present - but they don’t remind the eager learner of that fact.

I didn’t think you did. :wink:

The intention was for the OP… showing that there are plenty of resources to find on Internet, that might (or might not) be helpful. Cheers.

sudo pacman -S jdk21-openjdk
sudo archlinux-java set java-21-openjdk
java -jar SKlauncher-3.2.8.jar

I tried again with that version but still returns the same

didn’t work

Well, I installed the 3.2.5 version as @Nachlese menctioned.
Then I set Java 22 sudo archlinux-java set java-22-jdk

and it worked :v

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.