Error opening PCM device front:1: Device or resource busy - Dummy Output

suddenly $ pavucontrol (audio volume control) on Output tab shows “Dummy Output” device and no audio is played.

journalctl -xe --user-unit pulseaudio
pulseaudio[2316]: Error opening PCM device front:1: Device or resource busy

so i am wondering what is the command to discover which process is blocking the audio or how to fix it without reboot/logout.

i already tried:
closing web browser and audio/video apps
killall pulseaudio;pulseaudio -k
pulseaudio --start
systemctl restart pulseaudio*

$ inxi
Sound Server-1: ALSA v: k5.13.15-1-MANJARO running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: yes
Sound Server-4: PipeWire v: 0.3.35 running: no

$ sh /usr/bin/
here (p@ssw.: manjaro)

pulseaudio -vvv

Thank You


no, thanks, i want to fix it without rebooting as i have mentioned
UPDATE: this command seems to show processes using pulse audio:
sudo fuser -vu /dev/snd/* /dev/snd/by-path/*

the numbers are PIDs, to kill the process run command: sudo kill -9 PIDHERE

In my case i fixed this sound issue by killing mine installed audio players:
echo "mplayers killing";sudo kill -9 $(pidof vlc gnome-mplayer mplayer baka-mplayer) 2>/dev/null;echo "done"

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

PulseAudio is possibly blocked from accessing ALSA output because something is playing direct to ALSA and taking exclusive control of the audio device

MPV not play when Audacious running or in paused state