Error mounting USB drive


i have 2 USB HDDs, both same Model (WD USB3 MyPassport-series 4tb), both formated with NTFS and both have the exact same files and directories on it. I used them on my windows machine and now for over a year with XFCE manjaro (stable branch, i check updates every day). i had never any problems with these drives, i accessed both 2 days ago to copy some files on them without problem.

today i wanted to access them with thuna like i did hundreds of times before and both HDDs cant be mounted anymore, errormessage for both is:

“Error mounting /dev /sdc1 (sdd1 the other HDD) at /run/media/USERNAME/WD3 (WD5 the other HDD): wrong fs type, bad option, bad superblock on /dev/sdc1 (sdd1 the other HDD), missing codepage or helper program, or other error”

so the HDDs are physicaly detected and their names (WD3 and WD5) are also read out correctly.
they are also shown in the gparted software as ntfs partitioned. gparted also shows an info symbol. if i open the info i get the following warning:

"$MFTMirr does not match $MFT (record 3).
Failed to mount ‘/dev/sdc1’: Eingabe-/Ausgabefehler
NTFS is inconsistent. Run chkdsk /f on Windows then reboot it TWICE!
The usage of the /f parameter is very IMPORTANT! No modification was
made to NTFS by this software.

Failed to open ‘/dev/sdc1’.

$MFTMirr does not match $MFT (record 3).
Failed to mount ‘/dev/sdc1’: Input/output error
NTFS is inconsistent. Run chkdsk /f on Windows then reboot it TWICE!
The usage of the /f parameter is very IMPORTANT! No modification was
made to NTFS by this software.

Der Inhalt des Dateisystems konnte nicht gelesen werden!
Aufgrund dessen könnten einige Operationen nicht zur Verfügung stehen.
Die Ursache könnte ein fehlendes Softwarepaket sein.
Die folgende Liste zeigt die Softwarepakete, die zur Unterstützung des ntfs-Dateisystems erforderlich sind: ntfs-3g / ntfsprogs."

the data on these HDDs is extremly important for me, so i cant allow myself to “test around and hope for the best”, thats why i, before doing things worse in any way, open this thread. does anyone know what to do without risking complete dataloose? is this maybe a known problem, maybe some missing packages in pacman or somehing like this? hope someone can help me

Much easier to use search than type all that…

1 Like

Welcome to the forum! :vulcan_salute:

First of all, make sure that you blacklist the ntfs3 driver, like so… :point_down:

echo 'blacklist ntfs3' | sudo tee /etc/modprobe.d/disable-ntfs3.conf
sudo mkinitcpio -P
sudo update-grub

This will force the system to use the (much better) ntfs-3g driver.

Secondly, you must make sure that Windows Fast Startup (or whatever it’s called) is disabled, because it leaves your filesystems in an open state. Linux will detect this as filesystem damage.

Thirdly, do run a chkdsk /f on those filesystems from within Windows, just to be sure.

1 Like

Tried this, but HDDs still cant be mount, just the thunar error message changed to:

“Error mounting /dev/sdc1 at /run/media/USERNAME/WD5: Unknown error when mounting/dev/sdc1”

Then there’s likely something more serious wrong with it that can only be fixed with Windows as @Aragorn suggested.


Now that calls for confusion and possibly errors …

If you have used the disks in Windows and windows is in a hibernated state - the filesystems cannot be mounted by the kernel driver as they are marked as open in Windows.

You can avoid this by shutting down Windows completely - important: no hibernation and no fast startup.

Windows NTFS is a proprietary filesystem - any access from Linux is based on reverse engineered data - you should follow the advise

NTFS is inconsistent. Run chkdsk /f on Windows then reboot it TWICE!
The usage of the /f parameter is very IMPORTANT! No modification was
made to NTFS by this software.


the last time a windows system accessed these drives is over a year ago and in the meantime i accessed the drives with manjaro hundreds of times, last time 2 days ago. the only change to the system since than was a firefox update yesterday.

as i have no computer with windows available the chkdsk /f thing is a bit out of reach for me right now, damnit

Try Hiren’s Boot CD.

Then you have serious problems with the filesystem - NTFS is still proprietary and should never be used long term on Linux - there is no tools to fix the file system when it go bonkers.

Use - it is Window PE environment - you can fix the disk structure from inside that system.

If that is really the case - I suggest you convert your disks to ext4.


ok i will download and test the hirens bootimage, i will give answer here after i tested

little update:

downloaded the hirens iso image from homepage and tried to burn usb stick with the appimage of balena etcher. etcher says iso file is not bootable. i coninued creating the usb stick and well . . . it wasnt bootable.

then i installed gnome-multiwriter out of the repo. that programm dont warn about nonbootable iso-file. it shows writspeeds of 15-20mbyte . . . but the writing takes about 45 minutes, and short before the progress bar reaches 100% an error occurs “cant verify . . .” something like this.

then i tried terminal command sudo dd bs=4M if=/path/to/file.iso of=/dev/sdX status=progress oflag=sync. the usb stick created with this method is also not detected by bios as bootable device

oh how i hate those computerproblems out of the blue sky

There is a possibility that the ISO may have gotten corrupt during the download process. Commonly there will be a checksum or a file with a checksum with the ISO, and the idea is that after downloading, you run a checksum of the specified type — e.g. sha512 — against the ISO and compare it to the checksum listed on the site or in the checksum file.

Furthermore, the easiest way to put an ISO on a USB stick is with ventoy, which is in the repositories. With ventoy you don’t “burn” the ISO to the stick, but instead you format the stick with ventoy, and then you just drag and drop the ISO into the designated folder on the stick. You can put multiple ISOs on it like that (and easily remove them too), and it’ll give you a boot menu for each ISO it finds.


sudo pacman -S ventoy

hirens boot cd is a windows image - do not ever try to dd this to a stick or cdrw - you will fail

use ventoy as prescriped above.

1 Like

ok, i checked MD5 and the other checksumms and the file i downloaded is original.

then in got ventoy, prepared the usbstick, copied the iso image and when rebooting i end up in the ventoy bootmenu, so far so good. i see the imagefile, but no matter if i chose “boot in normal mode” or “boot in wimboot mode” (with an m) the following low res black and white screen freezes, a progress bar hangs at around 30 percent and thats it, waitet for 10 minutes, nothing happens.

Can you mount the devices manually?

sudo mount /dev/sdc1 /mnt

this gives back almost the same info as gparted:

“$MFTMirr does not match $MFT (record 3).
Failed to mount ‘/dev/sdc1’: Eingabe-/Ausgabefehler
NTFS is either inconsistent, or there is a hardware fault, or it’s a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the ‘dmraid’ documentation
for more details.”

If you can’t boot the latest PE version of Hiren’s BootCD then try the older 15.2 version.

ok i will try this out over the weekend, and if i find the time will also check one or two linux liveimages beside manjaro, maybe those behave differently.

i will update this thread

some updates on the issue:

i tried the older version of Hirens Boot CD (15.2), but it also doest boot into OS. Instead of Venoty offering “boot in normal mode” and “boot in wimboot mode”, ventoy offers “boot in normal mode”, “boot in grub2 mode” and “boot in memdisk mode”. no matter what i chose i have no success, for normal mode and grub2 a message is shown “no bootfile found for UEFI BIOS . . .”, thats it.

i also tried an old live image of manjaro and a live image of cinnamon mint, both OS cant access the drives (same error message as pasted above in this thread)

i have never worked with VM software before, anyway i downloaded Virtualbox out of the repo in hope to maybe boot the Hirens isos in a virtual machine, but this also doesnt work, Errormessage says something like “VT-x options disabled in BIOS”. the only option concerning virtual Machines i can find in bios is an Intel-Virtualisation Technology which is already set to enabled.

so far, so depressing