Error mounting HDD: Wrong fs type, bad option, bad superblock

Both the ntfs3 kernel driver and the ntfs-3g package should mount an NTFS file system (in an ideal world), and yet, sometimes ntfs3 fails. @megavolt suggestion to blacklist ntfs3 and install/use ntfs-3g is a valid workaround, and shouldn’t have any adverse affects. Cheers.

Again: When the ntfs3 driver detect any problems with your ntfs partition, then it will refuse to mount for safety reasons. On Windows you need to do chkdsk, on Linux there isn’t such a thing for ntfs.

See this: NTFS - ArchWiki

On Linux you can just remove the dirty bit and go on.

ntfsfix --clear-dirty /dev/sdXY

The reason for this bit is that Windows is forced then to check the drive and if no error was found, it will remove the bit. On Linux it will simply refuse to mount with ntfs3.


OK, great. So I just use

`sudo bash -c 'echo "blacklist ntfs3" > /etc/modprobe.d/disable-ntfs3.conf'`

Do I use

ntfsfix --clear-dirty /dev/sdXY?

Do so if think that the data was not corrupted (you are on your own then) otherwise check the data on Windows.

Thanks, megavolt.

I am still downloading Hirens iso and will try blacklisting workaround after @Mirdarthos advice to check through Windows. That way I can tell if data has been corrupted.

1 Like

My recomedation:
Use hirens, try to fix the partition so you can mount on linux.
Copy the data to somewhere.
Format the partition using a linux file system (like ext4).

Ntfs is not great on linux and you should not be surprised the data might become corrupted again if you keep it.

Yes, i will try that. Thanks, bedna.

Just to clarify:- The procedure to blacklist the ntfs3 kernel driver and use ntfs-3g will likely work; to the extent that the error will be ignored.

However, it won’t automagically fix it for you. If a disk error really exists, you will still need to run chkdsk as described – which now I notice the comment, you seem to be doing, so all is good.

Hi Mirdarthos,

I have downloaded the Hiren’s iso. Its size is 3 GB. I see on the download page there are reference notations for sha 1, MD5 , and sha-256 of the iso but I cannot find any links to download for these.

Should I ignore checksums and just go ahead burning the iso to usb?

There is no signature file. Copy and paste them manually, or compare the hashes manually…

Never ignore checksums (rule-of-thumb). Check the ISO locally, with whatever method you have available. In Dolphin, I can right-click an ISO file, and look in properties for the respective checksums. In XFCE, I don’t know if that feature is available. Compare the local generated checksum with those on the site. Usually if you can visually verify the first or last, (say, 8 characters) match, then the ISO should be fine.


Thank you, Mirdarthos and soundofthunder.

The checksums all check out.

Holy crap, you can even paste the checksum and it checks it.

I did not know about that, GREAT tip! :+1:

1 Like

I am going to be using balena_etcher to burn the iso. Is it okay to use if downloaded from the AUR repository?

I think so…

I am going to have to continue working on this tomorrow. Thank you mirthardos ,soundofthunder, bedna megavolt, linux-aarhus for your incredible support. I am very grateful and I hope you will be around tomorrow to help me further.


Hi Mirdarthos,

I ran chkdsk through the live boot Hiren’s and although I was unable to copy that output to share here, it said no problems were found with the file system. When I rebooted into Manjaro, I was able to access the HDD again. Do I need to do anything further for future access or will it always open now? I think chkdsk itself might have sorted out any issues but I want to be sure.

Thank you again for all your assistance.

Unless you use Windows you REALLY should not use ntfs.

1 Like

Make sure not to use the “Fast boot” option of Windoze (which is actually rather sening Windoze into hibernation), always shut it down properly as this could be the root cause of your issue and Windoze is prone to do this again.