Error message with "grub-install" after applying 2023-12-23 stable update

Please see attached picture of terminal-output.
My system is a GPT/BIOS installation
Kind regards, Ralf

There’s no such thing AFAIK. It’s UEFI/GPT, and MBR/BIOS IIRC.


But I see no EFI mount point, so… :eyes:

Perhaps you should check that your BIOS is in UEFI mode. Or something?

You can have a device with GPT partition table and legacy boot (non UEFI) . Generally you need to have a bios_grub partition where you write the bootloader, instead of doing it in MBR.

Welcome to Manjaro forum @wongs

For BIOS/GPT system

sudo grub-install --target=i386-pc --recheck /dev/sda1


sudo grub-mkconfig -o /boot/grub/grub.cfg

GRUB - ArchWiki

3. BIOS systems

3.1 GUID Partition Table (GPT) specific instructions

On a BIOS/GPT configuration, a BIOS boot partition is required. GRUB embeds its core.img into this partition.

1 Like

AH, well, then I’m out. Because except if the drive is faulty, then I don’'t know what would cause it to not be shown.

You can follow this thread that is currently under development. GPT/BIOS boot is possible, but I would leave that hornets nest afap and set up for EFI only if I were you.

Not entirely sure about that. I have not used GPT/BIOS mode but following the discussions on the forum about this right now seems to indicate not specifiing partition but rather just the device, ie sda instead of sda1 could be the way to go.
But as I said, I would leave that weird setup afap and go for efi only.

Thanks, but I’m fine with my hybrid setup as a multibooter.

  1. boot drive is a small SSD with legacy msdos partition table, grub written on this MBR, and the distro that controls grub.
  2. big hard drive contains most of my other distros, uses GPT partition table so I can have as many partitions as I want.

Back to this thread and the issue, I did read in the thread you pointed to that it might be possible to not have bio_grub partition for GPT/MBR-boot, but I believe the posts there indicated it might not work for some hardware? I can’t really help since my setup isn’t like that.

Then you have to deal with this frankenstein boot process, I say good luck in the future, this will act up again and again and again. The only fix is you figuring out exactly what YOU have to do every time you update any of the systems you are multibooting.

Then it seems the setup is not viable.
I have nothing more to add.
Good luck!

Nah, I’ve been using this on this machine since 2015, with Manjaro (Feb 2015 install) controlling boot. With help and input from gohlip, the grub guru who no longer frequents this forum, I have custom entries in custom.cfg to help boot the other distros without having to update-grub whenever a distro has a kernel change. I switched from normal Arch grub to Manjaro’s modded grub many years ago, and then when advised a few years ago, I switched back to the standard grub with no issues.

Updating grub and then running sudo grub-install /dev/sda after the latest updates was fine, as expected.

I have no problems with my setup, it’s the OP whose setup I can’t help with.

If commands suggested in post #3 are not working for you, download this script
script is still work-in-progress from Manjaro team but is working for my BIOS/MBR system

Install-grub: a new way to keep your EFI/MBR in-sync with grub package

OP has already tried install to MBR as shown in original screesnshot

The main problem for BIOS system users is confusing information from Manjaro Wiki

and misleading information from users that do not have accurate recall of how BIOS systems work

I’m not the OP. I was merely pointing out that you can have MBR [perhaps better described as legacy boot]/GPT, and that usually you need a bios_grub partition where you dump the bootloader. OP doesn’t have such a partition. That’s the extent of my contribution.

Witch is why I linked to the other post where they are trying to find out what has changed lately. When a proper conclusion has been made I’m sure they will edit the wiki.

What do you suggest they do? Remove the wiki page completely because things suddenly seems to have changed for gpt/bios setups? Instead of trying to figure out the best way to manage a bios/gpt setup?
What the wiki says is for MBR/bios users and GPT/efi, not GPT/bios IIRC.

If it was up to me, I would just say “good luck, you opt to use this really strange setup with 2 boot systems”.
I commend manjaro for doing this, its above and beyond imho.
There is also the script you linked to being made that might solve things for setups like that, I don’t follow the discussion too closely because I know how my setup works FOR ME and how to deal with things FOR ME just like it seems @wongs does. Even though I think he is :crazy_face: , although IMPRESSIVE :crazy_face: xD
(yes, I mistook you for OP) :slight_smile:

1 Like

I suggest you download install-grub script created by Manjaro Team

Or use this to find out the command used by calamares installer to install GRUB

sudo cat /var/log/calamares.log | grep 'grub-install'

So many posts with so little help… :thinking:

@RalfG , first you should 100% clearly identify if you have actually installed your system in BIOS mode or in UEFI mode. This can be achieved by the following command:

test -d /sys/firmware/efi && echo efi || echo bios

If your system is really BIOS/gpt you need a bios_grub partition. This could be located even before your currently first partition as only 32 kB size would be fine already, but certainly you could also create new /dev/sda3 partition for that, then I would make it at least 1 MiB large. This partition must not contain any file system (so not formatted) but must be marked as bios_grub partition by one of the following procedures:

  • Select partition type BIOS boot for fdisk.
  • Select partition type code ef02 for gdisk.
  • For parted set/activate the flag bios_grub on the partition.

Then you can re-install grub to it with exactly the command you used already.


Thanks for support so far, I’ll try @Wollie 's approach and will report later … :slight_smile:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.