Error message opening a Zoom invite link in Chromium

I am trying to set up a raspberry pi-powered Zoom-client box for some elderly friends of mine who are in their 90’s. These two are deathly afraid of technology, so making it as simple as possible is a must. I actually chose Manjaro because it seemed to work the best with Zoom in a browser compared to all of the other distros I tried (and I have tried downloading the zoom app using Box86 in Raspberry pi, which had severe lag even after overclocking.)

I am running into one crucial issue in making this as simple as possible for them. When I try to open up a zoom invite link, I get this error message:

Failed to open URI.
The specified location is not supported

zoommtg://$confno=[My Zoom MTG]&pwd=[Long list of random characters that in some way represent my password]%3D%3D&browser=chrome

I’m not sure what is going wrong here. I noticed in the URL of the error message, it has the portion “browser=chrome” and I wondered if, since this is technically Chromium, this has somehow caused an error? (I really have no idea and am guessing at this point)

Anyway, does anyone know what I can do? I want this to just automatically load up the meeting in browser like it does in Windows. Are there any config settings or files I can edit? Any help would be greatly appreciated.

That just means that the x-mime is not known. You will need to add this to your Desktop file. I guess it is this one:


Copy it to your home folder:

cp /usr/share/applications/Zoom.desktop ~/.local/share/applications/Zoom.desktop

and add there:



update-desktop-database ~/.local/share/applications/

and check if it is in the list:

cat ~/.local/share/applications/mimeinfo.cache

In general it should work then.

If I understand what you told me correctly, then these commands should help to open up the meeting in the Zoom app, correct? The problem there is that there is no Zoom.desktop in my applications folder because Zoom doesn’t have an application for ARM Linux. I’m trying to force it to open in the browser, but it keeps wanting to try to open it in the app.

Please let me know if I misunderstood. I did check /usr/share/applications, and there was no Zoom.desktop. I want chromium to launch the meeting.

The reason why it does not open is that the protocol name zoommtg is not known, just like a file extension like *.txt. If there is not set an application for it, then it will not open.

If you want chromium to open this protocol, add:


to its desktop file like described above. But I am not sure, if chromium can do that.

At least the browser have to know that the protocol is a known one and must refer to a real application.

Thanks for the help. I did try getting Chromium to launch it, but like you thought, it didn’t work. It just opened up a new window in Chromium. Is there a way to stop it from throwing that error? Maybe point it at a blank or benign process (if that means anything. . . )so that it doesn’t have any practical effect but also won’t throw the error?

Thanks for the pointers. I ended up creating my own zoom.desktop and using it to pass the arguments from zoommtg to a bash script that essentially did nothing with it. It at least rids me of the pop-up. Couldn’t have done it without your pointers, though.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.