Error message on clean install: No space left on device grub-install:

After booting to live media, and attempting to install Manjaro to an empty hard drive, I get this error at the end of installation:

Boost.Python error in job “bootloader”.
Command ‘grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --force’ returned non-zero exit status 1.
Installing for x86_64-efi platform. Could not prepare Boot variable: No space left on device grub-install: error: efibootmgr failed to register the boot entry: Input/output error.

File “/usr/lib/calamares/modules/bootloader/”, line 476, in run

File “/usr/lib/calamares/modules/bootloader/”, line 448, in prepare_bootloader
install_grub(efi_directory, fw_type)

File “/usr/lib/calamares/modules/bootloader/”, line 310, in install_grub

File “”, line 6, in

I have read this thread regarding possible causes. However, the possible cause given in it does not apply to me. The output of efibootmgr is not “unreasonably long”; it has only three entries. Nor am I running any variant of safe boot or legacy boot; I have set my boot to UEFI only and disabled safe boot. What further troubleshooting steps should I take?

1 Like

I have attempted the installation process with manual partitioning (300mb FAT32 with tag boot, mountpoint /boot/efi, remainder of drive ext4 with no tags, mountpoint /, 2mb unallocated), but encountered the same error message.

I have the same issue!

Forgot to update this, I inadvertently solved my own problem. Despite the error message, it seems that Manjaro did in fact install properly—when rebooting to try the installation again, I forgot to pick my live media in the boot menu, and my machine just booted to the entry at the top of the list, i.e. the newly-made Manjaro partition. So far, my installation has been working without issue. I’ll file a bug report with the Calamares installer about a potential false positive error message.

I was able to get the following to to make it work using the following

Check the output of:

# efibootmgr -v

If you have lots of entries then try deleting some that are not in use with

# efibootmgr -b xxxx -B

Replace xxxx with the boot number obtained from the output of the first command.

After removing some unneeded entries, there was no more “no space left on device” error and the installation was successful

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.