Error logging into Google online account

Hi All,

I noticed that the credentials for my Google account had expired in Gnome Online Accounts. After going through the login process again I get an error message saying “Failed to store credentials in the keyring.”

I tried removing the account, but got an error saying “GDBus.Error:org.freedesktop.Goa.Error.Failed: Failed to delete credentials from the keyring.”

I’ve done some searching but can’t find a solution. I’m on the stable branch, running kernel 5.7.17-2.

Thanks in advance for any help, and apologies if this has already been covered and I missed it.

I have the same problem and I tried with multiple google account, same errors.

I’m running kernel 5.8.16-2.

Did you found any solution?

Seems like a problem with gnome-keyring. Maybe reinstall that and if that doesn’t work, delete your keyring file and relogin. Note that deletes all the credentials in gnome-keyring.

1 Like

Simply reinstalling worked fine, and the same solution also fixed Online Accounts on Mint 19.3, that had had this problem since September. Thanks.