Error loading php intl after updating icu

Hello everyone,

I’m trying to run an app using php74, but I get the following error after a system update:

[PHP-FPM    ] Feb 12 11:10:46 |WARNING| FPM    Unable to load dynamic library 'intl' (tried: /usr/lib/php74/modules/intl (/usr/lib/php74/modules/intl: cannot open shared object file: No such file or directory), /usr/lib/php74/modules/ ( cannot open shared object file: No such file or directory))

‘intl’ won’t load, and the problem seems to be that icu has been updated to v74, as:

pacman -Q | grep icu 

gives me:

harfbuzz-icu 8.3.0-2
icu 74.2-1
lib32-icu 74.2-1

And indeed can’t be found anywhere.

‘php74-intl’ is up to date at v7.4.33-4.

‘yay -Syyu’ tells me that everything is up to date.

Tried to update mirrors list with

sudo pacman-mirrors -c all && sudo pacman -Syu 

but this didn’t change anything.

Thanks for anyone who can help in any way!

That is what happens on rolling release - php74 is build from custom AUR script.

please rebuild if that doesn’t help - contact the maintainer of the AUR script or move to php 8

1 Like

This is preferable, since no 7.x are supported anymore.

If you have to use 7.4, rather use some kind of container.

Okay, thank you for your replies. I’ll try running a container as the client doesn’t have the budget for a migration to php8.