Error kio client when opening zoom from terminal

i wrote a python program to automate the process of joining zoom meeting so the program executes the following command in terminal to join zoom meeting .

xdg-open "zoommtg://"

the program was working fine until today where it shows an error when this command is executed i previously installed zoom thorugh snap so I reinstalled it using yay it worked fine after reinstall but it started giving me the same error after a while

I got a similar error before a few days when trying to join a telegram group through browser but then i fixed it by pasting it on telegram and then clicking it

Error -- KIOexec
Unable to create io-slave. Unknown protocol 'tg'


I got this error when trying from chrome but firefox allowed me to choose an application so it worked with firefox

looks like kde has some bug with protocols

How do i get rid of this error
Is this a bug in kde

I’m not 100 percent sure but i think the error was triggered because i edited some .desktop files of zoom . I will close this as things have been working fine for while

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.