Error: Invalid sector size 65535 After Installation with Full Disk Encryption

Hello, I’m having trouble getting FDE to work on Manjaro Budgie. I’ve done a regular installation and it works just fine, however when I try to do an installation with Full Disk Encryption I get the error “invalid sector size 65535” above the request for the master key after Ive encrypted my drive through the installer. Once I type in my password it says 0 opened and gives me a number of different erro0rs every time I do it, followed by sending me into grub rescue. The errors seem to be different, like “invalid arch-independent ELF magic” error, among many different ones ive encountered over the last few days. Ive set the mount point to /boot/efi with boot and ESP flags for the 500 Mb fat32 boot partition, but that doesnt solve the issue. Ive tried the Discord “Linux For All” over the last few days, but not one seems to either way to help or doesnt know how, so Ive run out of ideas of what to do. Maybe someone can help me with my problem lol.

The drive is 4TB WD Blue internal hard dive. Ive also been able to encrypt the drive just fine in the past, so Im not sure whats the problem now lol.

can you boot on USB iso manjaro
open a terminal
and a browser on this topic
and reports

inxi -Fza
sudo parted -l

Well Im not sure how to post the output. When I tried to paste the output here, I got an error message saying I cant include links in my posts for some reason; and when I tried to upload pictures of the outputs, it said I cant include media in my posts. So im not sure how to post the output lol.

From your terminal:

  • Edit > Select all
  • Edit > Copy

Then paste (Ctrl+V) between 3 backticks:

Paste here

You can’t post links/media yet because you are newly registered. This is a spam prevention measure.

I tried … and . . . and neither worked =/

Sorry to hear that. What specifically doesn’t work?
Can you select and copy?
What happens when you try to paste?

Everything is fine from my end, but I still get he same spam prevention measure error when I paste the output with the little dots before and after the message like you said to do.


Umhhh. Can you paste at,

  • then click the save button,
  • then copy/paste the URL here
    Insert a space or something in http:// --> ht tp:// to work around the blocking rule.

Something like ht tps://

ht tps://

Here we go.

inxi -Fza

  Host: manjaro-budgie Kernel: 5.6.11-1-MANJARO x86_64 bits: 64 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC 
  driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=0 
  misobasedir=manjaro misolabel=MANJARO_BUDGIE_2001 quiet 
  systemd.show_status=1 apparmor=1 security=apparmor 
  Desktop: Budgie 10.5.1 Distro: Manjaro Linux 
  Type: Desktop Mobo: MSI model: X79A-GD45 Plus (MS-7760) v: 3.0 
  serial: <filter> UEFI: American Megatrends v: 17.9 date: 12/08/2014 
  Topology: Quad Core model: Intel Core i7-4820K bits: 64 type: MT MCP 
  family: 6 model-id: 3E (62) stepping: 4 microcode: 42E L2 cache: 10.0 MiB 
  Speed: 4000 MHz min/max: 1200/4000 MHz Core speeds (MHz): 1: 4000 2: 4000 
  3: 3998 4: 4001 5: 4000 6: 4000 7: 4004 8: 4000 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GK104 [GeForce GTX 760] driver: nvidia v: 440.82 
  Display: x11 server: 1.20.8 driver: nvidia 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: GeForce GTX 760/PCIe/SSE2 v: 4.6.0 NVIDIA 440.82 
  Device-1: Intel C600/X79 series High Definition Audio 
  driver: snd_hda_intel 
  Device-2: NVIDIA GK104 HDMI Audio driver: snd_hda_intel 
  Sound Server: ALSA v: k5.6.11-1-MANJARO 
  Device-1: Intel 82579V Gigabit Network driver: e1000e 
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Local Storage: total: 8.26 TiB used: 3.19 TiB (38.7%) 
  ID-1: /dev/sda vendor: A-Data model: SP900 size: 59.63 GiB block size: 
  physical: 512 B logical: 512 B 
  ID-2: /dev/sdb vendor: Western Digital model: WD40EZRZ-00WN9B0 
  size: 3.64 TiB block size: physical: 4096 B logical: 512 B 
  ID-3: /dev/sdc type: USB vendor: Western Digital 
  model: WD My Passport 2627 size: 4.55 TiB block size: physical: 4096 B 
  logical: 512 B 
  ID-4: /dev/sdd type: USB model: USB Flash Memory size: 14.45 GiB 
  block size: physical: 512 B logical: 512 B 
  ID-1: / raw size: N/A size: 5.77 GiB used: 928.7 MiB (15.7%) fs: overlay 
  source: ERR-102 
  System Temperatures: cpu: 50.0 C mobo: N/A gpu: nvidia temp: 49 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 43% 
  Processes: 278 Uptime: 1h 20m Memory: 7.69 GiB used: 1.90 GiB (24.8%) 
  Shell: bash inxi: 3.0.37

sudo parted -l

Model: ATA ADATA SP900 (scsi)
Disk /dev/sda: 64.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  64.0GB  64.0GB  primary               boot

Model: ATA WDC WD40EZRZ-00W (scsi)
Disk /dev/sdb: 4001GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name  Flags
 1      1049kB  538MB   537MB   fat32              boot, esp
 2      538MB   4001GB  4000GB  ext4

Model: WD My Passport 2627 (scsi)
Disk /dev/sdc: 5001GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name  Flags
 1      1049kB  5001GB  5001GB  ntfs               msftdata

Model:  USB Flash Memory (scsi)
Disk /dev/sdd: 15.5GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      2245MB  2249MB  4194kB  primary               esp

Opps I added the command for sudo parted -l in the middle of the output, oops lol. I forgot to add the commands originally and figured it would be easier if I added them, put it in the wrong place though lol.

I jumbled it back :slight_smile:

You’ll have to wait for @stephane or someone else to examine your initial issue, I’m not competent enough. I just chipped in to help with your pasting issue.

Oh okay, well thank you =p

time to check smart and test your WD 4000Gb disk
can you try to format with Gparted before install ?

What do I format it to?

in GPT , nothing else

Its been in GPT. I know you have to put it in GPT because MBR doesnt support over 2 TB.

If you prefer GUI install gsmartcontrol package and run SMART tests.

If you prefer CLI, install only smartmontools then head over there for instructions:
S.M.A.R.T. - ArchWiki.

I downloaded the GUI version and ran an extended test and it instantly completed with read failure. What does that mean?

In the Log it says:
LBA of the first error “17587000”

Is that the complete log?

To ensure your device supports smart (change sdb if needed):
$sudo smartctl --info /dev/sdb | grep 'SMART support is:'