Error installing plugin from file Calibre

EDIT: Solution Indeed, the guide below has version 6 of DeDRM, but Calibre 6.x requires a newer version as stated in the “windows” issue below.

Release v10.0.3 · noDRM/DeDRM_tools · GitHub Here is a link to the newer version that worked on my install.

Here’s a pastebin output.

I’ve just recently installed Manjaro (Gnome) on my desktop. Loving it so far, but I’m in the process of trying to get Calibre up and running correctly.

I’m specifically having difficulty installing the DeDRM plugin “from file.”

This is the guide I’m following, which is fine and not the issue…I’ve used it before on other distros just fine.

This error is the issue:


The output from this is what’s in the pastebin. I’m not very technically inclined, so I’m not exactly sure what I’m looking at here. I’m sure it’s simple. But it happened with the Official repository Calibre as well as the Flatpak one.

Try calibre-plugin-dedrm from the AUR instead of the plugin you manually tried to install. :arrow_down:

pamac build calibre-plugin-dedrm

Not sure if this helps but this kind of question has been asked before on the plugin site:

The question is for a windows installation but seems relevant or at least a good place to look further.
Edit: Or even better, above post!


Thanks for this, Aragorn! I’m sure this would have worked just fine, too.

Hanzel’s issue was indeed for a Window’s user, but it was the same error. Apparently there is a newer version of the plugin and the older versions don’t work with Calibre 6.x

I really appreciate you taking the time to suggest this, though. I wouldn’t have known how to enter that command without you telling me and I wouldn’t have come to that solution without your assistance.


Thanks for sharing this, @Hanzel !

I did take a look at this now that you shared it and indeed there is a much more updated version of the plugin from an entirely different user on GitHub and that much newer version of the plugin is required for Calibre 6.x

Thanks again!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.