Error Installing asusctl

I am getting an error trying to instal the AUR package asusctl. I am using an ASUS TUF FX517ZM laptop.

==> Starting build()...
cargo build --features "daemon cli" --release
error: failed to get `env_logger` as a dependency of package `supergfxctl v5.1.1 (/var/cache/private/pamac/supergfxctl/src/supergfxctl-5.1.1)`

Caused by:
  failed to create directory `/.cargo/registry/index/`

Caused by:
  Read-only file system (os error 30)
make: *** [Makefile:77: build] Error 101
==> ERROR: A failure occurred in build().
Finished with result: exit-code
Main processes terminated with: code=exited/status=4

I would be grateful for any assistance!

Welcome to the forum! :wave:

Please post the full output of pamac build asusctl, not just what you think is relevant. DO NOT use sudo with pamac.

:point_up_2: There’s your problem. Find out why the filesystem is read-only and you’ll have your answer. :man_shrugging:

Thank you for your help. I ran it without sudo and it worked just fine. I am new to Manjaro, and have been using APT based distros for a while.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.