Error in manpages

what if someone like me found an error in manpages. I am not allowed to post in your development-forum, so i must post it her.
It is about the “pamac list”-command.
First they show the operations and there it is. It shows this syntax

pamac list [options] <package(s)>
           List packages, groups, repositories or files

This is already wrong because the list-option doesn’t allow packages. Although I find it bad that this operation is not supported, it is unfortunately not supported.
You can compare this syntax with the explicit command below.
There it says

       List packages, groups, repositories or files

       pamac list [options]

The second description of the syntax is actually correct, which everyone can actually check for themselves and will notice that the complete list of packages is always listed and cannot be restricted, which I find a pity. Which in turn means that I personally found a mistake in the man-pages and I am proud of myself in a way, unless someone can prove me wrong.
I’m also wondering who to turn to in such cases, since I haven’t been with Manjaro that long. Am I allowed to change the open source myself in such cases or do I have to contact a responsible person?

Please create an upstream issue or Merge Request:

yesterday I registered there because I couldn’t log in with either my GitHub or my GitLab account, which surprised me.
I also wrote an e-mail to the above-mentioned e-mail address to enable faster access.
Today I tried to log in again and no matter which account login I use, I always get the same error message:

I didn’t even make a change request, just tried to login. Perhaps you can understand this by trying to log in yourself.

It is kind of strange right now and hope this temporary problem will be soluted soon.

Till then you may inform in forum when access will be possible.

@philm will activate your account when he finds time. There are hundreds of spam emails received in that inbox, so it’s hard to sort through. What was the subject of your email?

<package(s)> can be specified to show list of installed files

       List packages, groups, repositories or files

       pamac list [options]

           --files, -f <package(s)>
               list files owned by the given packages

pamac list --files does not work if name(s) of packages are omitted

Subject is
my registration for Manjaro Linux GitLab
sended 21.12.23 at 00:45 o’clock

You’re right, but -f is the only exception where you have to specify packages. All other options such as -i -e -o -m -g -r and -q do not require a package specification. The -f is in the 1:7 minority.
The other even more crucial argument to remove the from up there is that if you use it like that without an option, you will simply get an error message, so if you type pamac list packagename.
If you enter packages in conjunction with one of the other options, it implies to the user that the package was necessary and will be used, but in reality it will be ignored in 7 out of 8 cases.
I am not saying to remove it from pamac list -f, but only from pamac list.

Moderator edit: Fixed quotes

OK, now my account has been activated, i could log in and i already created an issue for that. (wasn’t able to create merge request, there was no button for that).

Let’s see how this develops and hope it will be fixed.

OK, thank you. This answer is quite useful. I am very new to GitLab and did’t ever make a merge request.
I even didn’t understand why going to pamac-cli, when issue is actually in the man pages. Isn’t there a man pages Project, where i belong to ? I mean i even don’t know the place where the files are stored which you have to edit, do you ?
How do you like my issue btw ?

The man pages are part of pamac-cli. See pamac.8.asciidoc & pamac.conf.5.asciidoc here:

Thanks for the report, I just pushed a fix :

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.