Error (firma PGP)

Hola

Hace dos dias me saltaron notificaciones para actualizar los paquetes, pero al hacerlo me pide actualizar las firmas de varios de ellos lo he intentando inclusive de forma manual pero siempre me salta el mensaje de error de que no se puede instalar por que no se confia en el paquete.

resolviendo dependencias…
buscando conflictos entre paquetes…

Paquetes (1) pamac-gtk-9.5.10-2

Tamaño total de la descarga: 0,14 MiB
Tamaño total de la instalación: 0,57 MiB
Tamaño neto tras actualizar: 0,00 MiB

:: ¿Continuar con la instalación? [S/n] S
:: Obteniendo los paquetes…
pamac-gtk-9.5.10-2-x86_64 143,8 KiB 236 KiB/s 00:01 [#########################################] 100%
(1/1) comprobando las claves del depósito [#########################################] 100%
(1/1) verificando la integridad de los paquetes [#########################################] 100%
error: pamac-gtk: se desconoce el nivel de confianza de la firma de «Helmut Stult (schinfo) helmut.stult@schinfo.de»
:: El archivo /var/cache/pacman/pkg/pamac-gtk-9.5.10-2-x86_64.pkg.tar.zst está dañado (paquete no válido o dañado (firma PGP)).
¿Quiere eliminarlo? [S/n] S
error: no se pudo realizar la operación (paquete no válido o dañado (firma PGP))
Ocurrieron errores, por lo que no se actualizaron los paquetes

ya he buscado y en san google y he hecho los procedimientos que indica para actualizar los repos de firmas pero nada sigue igual el mensaje.

9026 sudo pacman -Sy archlinux-keyring manjaro-keyring
9027 sudo pacman-key --populate archlinux manjaro
9028 sudo pacman-key --refresh-keys
9029 sudo pacman -Sc
9030 sudo rm -rf /etc/pacman.d/gnupg
9031 sudo pacman-mirrors -f 3 && sudo pacman -Syyu
9032 sudo pacman-key --init
9033 sudo pacman -Syu

Gracias por la ayuda.

¿Hiciste un sudo pacman-key --refresh-keys después de borrar el directorio /etc/pacman.d/gnupg?

¿Te sale esa firma si ejecutas sudo pacman-key -l | grep -i 'helmut'?

Prueba
sudo pacman -S archlinux-keyring manjaro-keyring
y despues
sudo pacman -Syu

O elige otro de los repos a ver

saludos, si hice todos esos pasos y sigue el problema; ahora acabo de hacer lo mismo y ahora tengo otros mensajes de error

sudo pacman-key --init 1 ↵
gpg: /etc/pacman.d/gnupg/trustdb.gpg: se ha creado base de datos de confianza
gpg: no se encuentran claves absolutamente fiables
gpg: starting migration from earlier GnuPG versions
gpg: porting secret keys from ‘/etc/pacman.d/gnupg/secring.gpg’ to gpg-agent
gpg: migration succeeded
gpg: Generating pacman keyring master key…
gpg: clave DF492C710E8FECE4 marcada como de confianza absoluta
gpg: creado el directorio ‘/etc/pacman.d/gnupg/openpgp-revocs.d’
gpg: certificado de revocación guardado como ‘/etc/pacman.d/gnupg/openpgp-revocs.d/BE80B8B6245F1DE1A2D0DC44DF492C710E8FECE4.rev’
gpg: Done
==> Actualizando la base de datos de claves de confianza…
gpg: marginals needed: 3 completes needed: 1 trust model: pgp
gpg: nivel: 0 validez: 1 firmada: 0 confianza: 0-, 0q, 0n, 0m, 0f, 1u

sudo pacman-key --refresh-keys
gpg: renovando 1 clave desde hkps://hkps.pool.sks-keyservers.net
gpg: renovación al servidor de claves fallida: Error general
==> ERROR: La clave local especificada no se pudo actualizar desde un servidor de claves.

sudo pacman-key -l | grep -i ‘helmut’
esto no me devuelve nada

sudo pacman -S archlinux-keyring manjaro-keyring
advertencia: archlinux-keyring-20200820-1 está actualizado – reinstalándolo
advertencia: manjaro-keyring-20200603-1 está actualizado – reinstalándolo
resolviendo dependencias…
buscando conflictos entre paquetes…

Paquetes (2) archlinux-keyring-20200820-1 manjaro-keyring-20200603-1

Tamaño total de la instalación: 1,45 MiB
Tamaño neto tras actualizar: 0,00 MiB

:: ¿Continuar con la instalación? [S/n] S
(2/2) comprobando las claves del depósito [#########################################] 100%
descargando las claves necesarias…
:: ¿Importar clave PGP 6D42BDD116E0068F, «Christian Hesse arch@eworm.de»? [S/n] S
:: ¿Importar clave PGP CAA6A59611C7F07E, «Philip Mueller philm@manjaro.org»? [S/n] S
error: no se pudo buscar la clave «CAA6A59611C7F07E» de forma remota
error: la clave necesaria no está presente en el depósito
error: no se pudo realizar la operación (error inesperado)
Ocurrieron errores, por lo que no se actualizaron los paquetes

Prueba con:

sudo pacman-key --populate archlinux manjaro
sudo pacman-key --keyserver pool.sks-keyservers.net --refresh-keys