Error: Failed to prepare transaction: target not found: podofo-0.9

Hi folks,
I’m unable to update using the GUI Add/Remove Software and I get this error message:
“unable to lock database
Failed to synchronize databases
Warning: installing openblas (0.3.23-3) breaks dependency ‘blas’ required by cblas
Add cblas to remove”

I did a bit of snooping around here for something that might be helpful and tried this in the Konsole:
“pamac update --force-refresh”
This failed to complete giving me the error message:
“Error: Failed to prepare transaction: target not found: podofo-0.9”

Does anyone here have any suggestions as to what I should do next?

You have to choose with BLAS implementation you want to use:
sudo pacman -Syu blas-openblas

But first, you probably have to update your mirrors: sudo pacman-mirrors --geoip

1 Like

Thanks so much for the swift response. Just running it now. I’ll update with the outcome.

That took a few hours to run. It did complete but there were a few errors and warnings showing when I scrolled back up through the CL. Now, when i attempt to update using the GUI I get the error message in this screen grab…

Then use the terminal:

sudo pacman-mirrors --geoip
sudo rm -rf /var/tmp/pamac
sudo pacman -Syyu

Please don’t post screenshots of this very simple error message. Just post it.

Sorry about the big screenshot for very little content. I guess it wastes a lot of bandwidth and wasn’t thinking.
I had already tried the terminal, and have just tried it again to receive this message:
“:: Starting full system upgrade…
warning: manjaro-hello: local (0.7.0-6) is newer than extra (0.7.0-5)
there is nothing to do”
Does this mean that I should just stop worrying about everything and carry on using my computer, or is there some kind of mess that I need to clear up first?
Sorry about all the questions. As you might gather, I’m no expert and generally tend to blunder my way through things.

Found the solution here. Thanks everyone…