Error: failed to prepare transaction (could not satisfy dependencies) :: installing nvidia-utils (495.44-6) breaks dependency ‘nvidia-utils=470.63.01’ required by linux513-nvidia Unable to update or to add new kernels

I have a very similar problem to an old topic with the same error message

Howether when i try to add a new kernel, i get the exact same message, should i pacman -r the package and reinstall it after the update is done ?

What about posting some information ?
Please have a look at: “How to get help”, “How to provide Information”

  Kernel: 5.13.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64
  root=UUID=6900f3c2-083c-41e6-a2ac-280c3f110cba rw quiet apparmor=1
  security=apparmor udev.log_priority=3
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: G11CB v: Rev 1.xx serial: <filter>
  UEFI: American Megatrends v: 0802 date: 02/04/2016
  Message: No system battery data found. Is one present?
  RAM: total: 15.56 GiB used: 5.16 GiB (33.2%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: Quad Core model: Intel Core i7-6700 bits: 64 type: MT MCP
  arch: Skylake-S family: 6 model-id: 5E (94) stepping: 3 microcode: EA cache:
  L2: 8 MiB bogomips: 54417
  Speed: 3768 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 3768 2: 3729
  3: 3800 4: 3741 5: 3800 6: 3795 7: 3783 8: 3793
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr hle ht hwp hwp_act_window
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts
  rdrand rdseed rdtscp rep_good rtm sdbg sep smap smep smx ss ssbd sse sse2
  sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt
  xsaves xtopology xtpr
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
  IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable
  Device-1: NVIDIA GM206 [GeForce GTX 950] vendor: ASUSTeK driver: nvidia
  v: 470.63.01 alternate: nouveau,nvidia_drm bus-ID: 01:00.0
  chip-ID: 10de:1402 class-ID: 0300
  Display: x11 server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver:
  loaded: nvidia display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 3600x1080 s-dpi: 96 s-size: 953x286mm (37.5x11.3")
  s-diag: 995mm (39.2")
  Monitor-1: DVI-I-0 res: 1680x1050 hz: 60 dpi: 90
  size: 474x296mm (18.7x11.7") diag: 559mm (22")
  Monitor-2: HDMI-0 res: 1920x1080 hz: 60 dpi: 93 size: 527x296mm (20.7x11.7")
  diag: 604mm (23.8")
  OpenGL: renderer: NVIDIA GeForce GTX 950/PCIe/SSE2 v: 4.6.0 NVIDIA 470.63.01
  direct render: Yes
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK
  driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a170
  class-ID: 0403
  Device-2: NVIDIA GM206 High Definition Audio vendor: ASUSTeK
  driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:0fba
  class-ID: 0403
  Device-3: Kingston HyperX Cloud Flight Wireless type: USB
  driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-1:2 chip-ID: 0951:1723
  class-ID: 0300
  Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.38 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: ASUSTeK driver: r8169 v: kernel port: d000 bus-ID: 02:00.0
  chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter
  vendor: AzureWave driver: rtl8821ae v: kernel port: c000 bus-ID: 03:00.0
  chip-ID: 10ec:8821 class-ID: 0280
  IF: wlp3s0 state: down mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  WAN IP: <filter>
  Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8
  bus-ID: 1-7:5 chip-ID: 13d3:3414 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
  rfk-block: hardware: no software: yes address: see --recommends
  Message: No logical block device data found.
  Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 port: f020
  bus-ID: 00:17.0 chip-ID: 8086:2822 rev: N/A class-ID: 0104
  Local Storage: total: 931.51 GiB used: 469.76 GiB (50.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: DT01ACA100
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
  type: HDD rpm: 7200 serial: <filter> rev: A7L0 scheme: GPT
  Optical-1: /dev/sr0 vendor: ASUS model: SH-224FB rev: 1.00 dev-links: cdrom
  Features: speed: 48 multisession: yes audio: yes dvd: yes
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 931.22 GiB size: 915.53 GiB (98.32%)
  used: 469.76 GiB (51.3%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
  uuid: 6900f3c2-083c-41e6-a2ac-280c3f110cba
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
  used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL
  uuid: 5FAE-6546
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-1:2 info: Kingston HyperX Cloud Flight Wireless type: Audio,HID
  driver: hid-generic,snd-usb-audio,usbhid interfaces: 4 rev: 1.1
  speed: 12 Mb/s power: 100mA chip-ID: 0951:1723 class-ID: 0300
  Device-2: 1-6:4 info: SHARKOON Gaming Keyboard type: Keyboard,HID
  driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s
  power: 100mA chip-ID: 1ea7:2002 class-ID: 0300
  Device-3: 1-7:5 info: IMC Networks Bluetooth Radio type: Bluetooth
  driver: btusb interfaces: 2 rev: 2.1 speed: 12 Mb/s power: 500mA
  chip-ID: 13d3:3414 class-ID: e001 serial: <filter>
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.0 speed: 5 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-1:2 info: SteelSeries ApS SteelSeries Rival 100 Gaming Mouse
  type: HID,Mouse driver: hid-generic,usbhid interfaces: 2 rev: 1.1
  speed: 12 Mb/s power: 130mA chip-ID: 1038:1702 class-ID: 0301
  Device-2: 3-2:3 info: Microdia USB Keyboard type: Keyboard
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 1.5 Mb/s
  power: 100mA chip-ID: 0c45:7605 class-ID: 0301
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 67.0 C mobo: 27.8 C gpu: nvidia temp: 47 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 32%
  Processes: 310 Uptime: 10h 58m wakeups: 0 Init: systemd v: 249
  tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 1285
  pacman: 1258 lib: 362 flatpak: 0 snap: 27 Shell: Bash v: 5.1.8 
  running-in: xfce4-terminal inxi: 3.3.08```

Kernel 5.13 has been EOL for some time now. Change that first of everything, reboot and see if the problem persists. And use mhwd-kernel to do so, not pacman, as it does an extremely good job of it.

when i try to change my kernel it gives me the same error.

Then you’d have to boot with a live ISO and do it from a chroot environment.

okay i will try that, any precaution i can take before i do ?

Don’t think so.

Just be sure that while you’re busy, you don’t assume something, because when you change into the chroot environment you are root on your actual system, so it’s extremely important to be careful then because any- and everything you do will have lasting consequences.

1 Like

They may not need to do the chroot thing. When I had a similar issue a few years ago, the steps I took were:

  1. Uninstall the nvidia driver,
  2. Install new kernel
  3. Uninstall old kernel
  4. Install nvidia driver.
  5. Reboot to start using the new kernel & nvidia driver.

*I did no rebooting between steps 1-4, I also did not use pacman or a package manger to do this, I used manjaro settings manager tool to handle it.

*If I remember correctly, cuda if installed may need to be uninstalled for these steps to work (reinstall it afterwards if needed).

This issue is actually hit or miss. By that install from the last stable ISO that has the 5.13 kernel and try to update once on the desktop and one time ISO will update without issue and the next time it won’t because of the above. Users that want to install Manjaro right now need to make sure they grab the release candidate that’s out.

May being they key phrase…

I’m assuming “many” should be “may”.

That might very well be true. It might also not. I prefer to go with the route I’m familiar with and know will work, and from what I can see, chroot will work.

1 Like

Okay si managed to change the kernel without the chroot, i made back ups just to be sure, i’m on 5.10 now so i’ll try to update see if it goes through ( i didnt have a live iso on hand and since everything is backed up i took the risk, not saying it was the right thing to do)


Do updates with pamac and not pacman for the same reason I recommended mhwd-kernel.


Yep Thank you all, the update went fine !

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.