Error: failed to commit transaction (invalid or corrupted package (PGP signature))

Hi there,

So I tried to update but I had the error - failed to commit transaction (invalid or corrupted package (PGP signature)). After that, I tried some suggestions from form. Nothing worked. I tried pacman-key --init pacman-key --populate, I tried clear the entire cache. But after that I get the following:

core.db failed to download
 extra.db failed to download
 multilib.db failed to download
error: failed retrieving file 'multilib.db' from : The file does not exist
error: failed retrieving file 'core.db' from : The file does not exist
error: failed retrieving file 'extra.db' from : The file does not exist
warning: too many errors from, skipping for the remainder of this transaction
error: failed to synchronize all databases (download library error)

is it better to just use timeshift?

here is info:

  Kernel: 6.5.5-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.5-x86_64
    root=UUID=e4ad81d4-7731-470f-a969-f7c198f5731a rw quiet splash
    udev.log_priority=3 nvidia-drm.modeset=1
  Desktop: KDE Plasma v: 5.27.8 tk: Qt v: 5.15.11 info: latte-dock
    wm: kwin_wayland vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 82UX v: Lenovo Slim 7 16ARH7
    serial: <superuser required> Chassis: type: 10 v: Lenovo Slim 7 16ARH7
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0T76530 WIN
    serial: <superuser required> UEFI: LENOVO v: KLCN19WW date: 06/08/2023
  ID-1: BAT0 charge: 49.7 Wh (75.0%) condition: 66.3/75.0 Wh (88.4%)
    volts: 15.8 min: 15.4 model: LENOVO AP16L5J type: Li-ion serial: <filter>
    status: not charging cycles: 113
  Device-1: apple_mfi_fastcharge model: N/A serial: N/A charge: N/A
    status: N/A
  Info: model: AMD Ryzen 7 6800HS Creator Edition bits: 64 type: MT MCP
    arch: Zen 3+ gen: 4 level: v3 note: check built: 2022 process: TSMC n6 (7nm)
    family: 0x19 (25) model-id: 0x44 (68) stepping: 1 microcode: 0xA404102
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB L3: 16 MiB
    desc: 1x16 MiB
  Speed (MHz): avg: 949 high: 2472 min/max: 400/4785 scaling:
    driver: amd-pstate-epp governor: powersave cores: 1: 1755 2: 1397 3: 400
    4: 400 5: 400 6: 400 7: 400 8: 2472 9: 1396 10: 400 11: 1396 12: 400
    13: 1778 14: 400 15: 1397 16: 400 bogomips: 102253
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow mitigation: safe RET, no microcode
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GA107BM [GeForce RTX 3050 Mobile] vendor: Lenovo
    driver: nvidia v: 535.113.01 alternate: nouveau,nvidia_drm non-free: 535.xx+
    status: current (as of 2023-09) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-23 pcie: gen: 1 speed: 2.5 GT/s lanes: 8
    link-max: gen: 4 speed: 16 GT/s lanes: 16 ports: active: none empty: eDP-1
    bus-ID: 01:00.0 chip-ID: 10de:25e2 class-ID: 0300
  Device-2: AMD Rembrandt [Radeon 680M] vendor: Lenovo driver: amdgpu
    v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22
    pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: HDMI-A-1,eDP-2
    empty: DP-1, DP-2, DP-3, DP-4, DP-5, DP-6, DP-7 bus-ID: 05:00.0
    chip-ID: 1002:1681 class-ID: 0300 temp: 46.0 C
  Device-3: IMC Networks Integrated RGB Camera driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 5-1:2 chip-ID: 13d3:5285
    class-ID: fe01 serial: <filter>
  Display: wayland server: v: with: Xwayland v: 23.2.1
    compositor: kwin_wayland driver: X: loaded: amdgpu,nvidia
    unloaded: modesetting,nouveau alternate: fbdev,nv,vesa dri: radeonsi
    gpu: nvidia,amdgpu d-rect: 3627x1080 display-ID: 0
  Monitor-1: HDMI-A-1 pos: primary,left res: 1920x1080 size: N/A modes: N/A
  Monitor-2: eDP-2 pos: right res: 1707x1067 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: nvidia drv: amd radeonsi platforms: device: 0
    drv: nvidia device: 1 drv: radeonsi device: 3 drv: swrast surfaceless:
    drv: nvidia wayland: drv: radeonsi x11: drv: radeonsi
    inactive: gbm,device-2
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 23.1.9-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (rembrandt LLVM
    16.0.6 DRM 3.54 6.5.5-1-MANJARO) device-ID: 1002:1681 memory: 1.95 GiB
    unified: no display-ID: :1.0
  API: Vulkan v: 1.3.264 layers: 1 device: 0 type: discrete-gpu name: NVIDIA
    GeForce RTX 3050 Laptop GPU driver: nvidia v: 535.113.01
    device-ID: 10de:25e2 surfaces: xcb,xlib,wayland device: 1
    type: integrated-gpu name: AMD Radeon Graphics (RADV REMBRANDT)
    driver: mesa radv v: 23.1.9-manjaro1.1 device-ID: 1002:1681
    surfaces: xcb,xlib,wayland
  Device-1: AMD Rembrandt Radeon High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 05:00.1 chip-ID: 1002:1640 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo
    driver: snd_pci_acp6x v: kernel alternate: snd_pci_acp3x, snd_rn_pci_acp3x,
    snd_pci_acp5x, snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps,
    snd_sof_amd_renoir, snd_sof_amd_rembrandt pcie: gen: 4 speed: 16 GT/s
    lanes: 16 bus-ID: 05:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 05:00.6
    chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.5.5-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.81 status: off with: pipewire-media-session
    status: active tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
  Device-1: Realtek vendor: Lenovo driver: rtw89_8852be v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 02:00.0 chip-ID: 10ec:b852
    class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  Device-2: KYE Systems (Mouse Systems) GF3000F Ethernet Adapter
    driver: hid-generic,usbhid type: USB rev: 1.1 speed: 12 Mb/s lanes: 1
    mode: 1.1 bus-ID: 3-1:2 chip-ID: 0458:6001 class-ID: 0301
  IF-ID-1: enp5s0f4u2c4i2 state: down mac: <filter>
  Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 1.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-3:3 chip-ID: 0bda:4853
    class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Local Storage: total: 931.51 GiB used: 97.11 GiB (10.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: WD BLACK SN850X 1000GB size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 620311WD temp: 42.9 C scheme: GPT
  ID-1: / raw-size: 587.49 GiB size: 577.2 GiB (98.25%) used: 97.04 GiB (16.8%)
    fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 67.5 MiB (26.4%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 56.9 C mobo: N/A gpu: amdgpu temp: 49.0 C
  Fan Speeds (rpm): N/A
  Processes: 401 Uptime: 1h 11m wakeups: 2037 Memory: total: 16 GiB note: est.
  available: 13.34 GiB used: 7.27 GiB (54.5%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: pm: pacman pkgs: 1404 libs: 397 tools: octopi,pamac,yay pm: flatpak
  pkgs: 0 Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.30

If you need anything else please let me know. Thank you


Thank you for the reply. I followed the suggestions but got the following

:: Retrieving packages...
 archlinux-keyring-202...  1169.3 KiB  5.29 MiB/s 00:00 [#############################] 100%
(11/11) checking keys in keyring                        [#############################] 100%
(11/11) checking package integrity                      [#############################] 100%
error: archlinux-keyring: signature from "Christian Hesse <>" is unknown trust
:: File /var/cache/pacman/pkg/archlinux-keyring-20231026-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

It may be due to obsolete PGP keys or Arch-signed packages in the repositories.

  1. Reinstall keyrings including the latest keys:
sudo pacman -Sy archlinux-keyring manjaro-keyring

If you can’t install the keyring because of signature errors, perform step 2 and repeat 1, otherwise proceed to step 3.

  1. Remove old and possibly expired, revoked or invalid keys by issuing this command:
sudo rm -r /etc/pacman.d/gnupg
  1. Initialize the pacman keyring:
sudo pacman-key --init
  1. Load the signature keys:
sudo pacman-key --populate archlinux artix
  1. Clear out the software packages downloaded during the aborted installation:
sudo pacman -Scc
sudo pacman -Syyu

Answer based off: Wiki | Main / Troubleshooting


Unfortunately, this did not work either. I did step 1, got the errors, did step two, and got this error.

error: keyring is not writable
error: keyring is not writable
error: required key missing from keyring
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.

so I did in the following order and it worked

sudo pacman-key --init 
sudo pacman-key --refresh-keys
sudo pacman-key --populate archlinux manjaro
sudo pacman -Sy archlinux-keyring manjaro-keyring
sudo pacman -Scc
sudo pacman -Syyu

Thank you so much! : )

1 Like

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.