Error: end of file /boot/vmlinuz-6.1-x86_64

Please forgive my lack of understanding I used windows for most of my life.
I was updating using AUR in the background and trying to use adb to get into a broken phone I noticed that my start menu had no icons like it was empty. I thought I messed something up running the adb commands on my laptop and not connecting to the phone to run the commands. I noticed there was an error with the update but didn’t read it before restarting.
I then get this error when booting.

Error: end of file /boot/vmlinuz-6.1-x86_64

I tried going into advanced options but unfortunately the fallback is the exact same kernel version as the default and doesn’t work either.
I have looked at other threads that have similar issues and made a live Manjaro usb so I can boot into that and repair the one on my system however my disk has full encryption so I am at a loss as to how to do this.

Something like this:


Thanks for this. Will this work if I have full disk encryption? Because booting into the Manjaro live never gives me the decrypt prompt.

When I try to run
manjaro-chroot -a
I get
grub-probe: error: cannot find a GRUB drive for dev/sdb1. Check your
ERROR: No Linux partitions detected!

Looks l ike there is a guide for encrypted here:


After much trial and error I made some progress doing the following…

sudo su -

cryptsetup luksOpen /dev/nvme0n1p1 ssd

sudo mount /dev/mapper/ssd /mnt

sudo manjaro-chroot /mnt

Then the prompt changed to Sh-5.2#

[ -f /var/lib/pacman/db.lck ] && rm -f /var/lib/pacman/db.lck

pacman-mirrors -f && pacman -Syyu

So far no errors until I run


I get his output

Generating grub configuration file …

Found theme: /usr/share/grub/themes/manjaro/theme.txt

Found lunux image: /boot/vmlinuz-6.1-x86_64

Found initrd image: /boot/intel-ucode.img

Warning: os-prober will be executed to detect other bootable partitions.

Its output will be used to detect bootable binaries on them and create new boot entries.

ERROR: mkdir /var/lock/dmraid

grub-probe: error: cannot find a GRIB drive for /dev/sdb1. Check your

Adding boot menu entry for UEFI Firmware Settings …

Found memtest86+ image: /boot/memtest86+/memtest.bin


I restart and pull out the flash drive. I am prompted for my password but after I get the same error.
Error: end of file /boot/vmlinuz-6.1-x86_64
Error: you need to load the kernal first

Your kernel-file is damaged, while grub thinks it is OK. So, best is to add another kernel.

While in chroot,

  • try to install (add) kernel 6.6
    with: sudo mhwd-kernel -i linux66
  • reboot into kernel 6.6
  • remove kernel 6.1
  • reinstall kernel 6.1
1 Like

While in chroot I used that command. It doesnt give me any output and just went down to the next line. It is not installing any new kernels when I check with
mhwd-kernel -li

What am I doing wrong?

Then your kernel is not installed correctly. :rofl:

please try:
mhwd-kernel -l

I did ask for:

Please provide (copy / paste) full output ! Do not only describe what happens !

When I use the command
sudo mhwd-kernel -i linux66
It just goes to the next line and doesn’t give me any feedback to share with you. I tried various different kernels with the same result.

I used
mhwd-kernel -li
To see if the any new kernels were installed.
It shows

Currently running: 6.5.5-1-MANJARO (linux65)
The following kernels are installed in your system:

When I run
mhwd-kernel -l
I get
Available kernels:

Then that’s out of my league :man_shrugging:

For some reason using
sudo mhwd-kernel -i linux66
Does nothing
but if I try
mhwd-kernel -i linux66
I get
Synchronizing package databases…
Core 100%
Extra 100%
Community is up to date
Multilib is up to date
Error: no targets specified (use -h for help)

If you are in chroot that makes perfect sense, since you ARE root and sudo should not be used.
I haven’t actually read the whoe thread you pulled me in here from another remember.

But you could try to install with pacman instead.

1 Like
pacman -S linux66

From the chroot of course (#). Hopefully mirrors are synced.


I installed and tried every kernel I the furthest I got was a login screen which would just ask me to relog in once I already had logged in.
I think my issue is the same as this thread.

At this point I want to copy the contents of my whole drive to an external and do a fresh install.

Would I use rsync to do this? I just dont understand what the path is out of my unencrypted drive once I have done the mounting and chrooting into my encrypted drive.

I found that dolphin file manager could do what I needed. I used AUR on the USB run manjaro to install it and then didnt restart my machine. I right clicked the external drive and set it to modify files so I could copy everything over there.
I hadnt realized that using AUR could do this to my system. Thanks for all your help!

Nobody understood what you just said :slight_smile:

1 Like

Please do not do this again :wink:
The problem is not AUR itself

Some things that others can learn from it

It cannot be said often enough:

  • Do update in a terminal
  • Do read the update-thread ahead of it
  • Do read error-messages
  • Do update AUR only if you already updated the base-system without errors


  • In principle, saving an encrypted system is much more difficult than saving an unencrypted one. (> 1 day)
  • Backups help you not to have to put in too much effort in the event of a crash, but rather to be able to simply reinstall and restore your data. (1 hour)
  • Timeshift / snapper and btrfs help you get out of a crash with a simple rollback (5 minutes)
1 Like