Error: diskfilter writes are not supported (LVM issue)

Hi there,
I installed Manjaro KDE Plasma inside an lvm partition through the normal installer (not Architect), using custom partitioning.
when I start Manjaro, immediately after GRUB bootmenu, this error
error: diskfilter writes are not supported
appears for few seconds or until I pres any key. I read on a askubuntu post (I can’t insert links since I’m a newbie in this forum, but you can rebuild the link adding the following “/questions/468466/diskfilter-writes-are-not-supported-what-triggers-this-error#498281” to the site URL) that this is a known BUG due to GRUB being unable to write recordfail’s output onto an lvm (or RAID) partition.

This error is coded inside /etc/grub.d/00_header, into recordfail calls for save_env statements, so I followed the steps suggested, patching the file, but I had no luck. Maybe the reason is the patched 00_header they provide are meant for a different distribution?
I also tried to dig more and manually disable recordfail but my knowledge in GRUB code and advanced shell scripting isn’t wide enough…

Could anybody fix it or let me know how to directly report this bug to the developers team in charge for grub? I’m quite a newbie in bugreports :slight_smile:
Thanks a lot.


I had this error initially when I ran update-grub from a Ubuntu 20.04 albeit having set GRUB_SAVDEFAULT=false in /etc/default/grub.

With GRUB_SAVDEFAULT=false in /etc/default/grub and running update-grub from Manjaro it is fine.

(Manjaro and Ubuntu 20.04 roots in LVM, /boot/efi not in LVM)