ERROR: device 'UUID=<device_uuid>' not found. Skipping fsck

Hi all,

I installed via USB the Manjaro OS with i3. I have done it before with a Lenovo ThinkPad, now I’m doing it for a Lenovo IdeaPad 5, with no OS preinstalled. But when it finishes and I reboot, I got an error:
ERROR: device ‘UUID=<uuid_number>’ not found. Skipping fsck
mount: /new_root: can’t find UUID=<device_uuid>.

But I checked and it has the correct UUID. I checked from the pendrive while live booting it.

When I run sudo mount /dev/nvme0n1p2 /mnt and then cat /mnt/etc/fstab I get:

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system> <mount point> <type> <options> <dump> <pass>

UUID=<blah> /boot/efi vfat umask=0077 0 2
UUID=<dev_uuid> / ext4 defaults,noatime 0 1

When I run lsblk -f:

loop0 squash 4.0
loop1 squash 4.0
loop2 squash 4.0
loop3 squash 4.0
sda iso966 Jolie MANJARO_I3_2104 2021-05-06-20-54-26-00
├─sda1 iso966 Jolie MANJARO_I3_2104 2021-05-06-20-54-26-00
└─sda2 vfat FAT12 MISO_EFI 384D-6074
├─nvme0n1p1 vfat FAT32 NO_LABEL 6727-60C4
└─nvme0n1p2 ext4 1.0 78e85b35-d483-4258-8a36-4ae

I also looked at /mnt/boot/grub/grub.cfg and the UUIDs are ok.

1 Like

I assume that sda is the installation media?
Are you still booting from the insallation media and not the installed Manjaro on the nvme ssd?

Your fstab on the installed version should have 6727-60C4 as <blah> and 78e85b35-d483-4258-8a36-4ae as <dev_uuid> is that correct?

Yes the sda is the installation media (my flash drive of almost 4GB).

I also booted with the pendrive removed and still get the error.

These are the values of the UUIDs:

UUID=6727-60C4 /boot/efi vfat umask=0077 0 2
UUID=78e85b35-d483-4258-8a36-4ae5550e9430 / ext4 defaults,noatime 0 1

That looks good to me. Maybe there’s an issue with the grub config. But I don’t know how to work with this, maybe someone else can help you furhter.

I see, anyway thank you!

On the Manjaro Wiki there’s an article called GRUB/Restore the GRUB Bootloader - Manjaro. Maybe this fixes the problem…

Edit: link to wiki

Doesn’t look good to me, 5550e9430 is not part of the UUID you posted. :slight_smile:

1 Like

I’ll check it!

Oh you think those extra characters shouldn’t be there? I’ll try to remove those and try again then. Or how can I know if they’re correct?

lsblk -o UUID /dev/nvme0n1p2

By the way, the fsck is not run from within GRUB. It’s run from within the initramfs. So if fixing the UUID in /etc/fstab doesn’t work, then you may need to rebuild the initramfs.

sudo mkinitcpio -P
1 Like

Yes it throws me this:

Okay I ran this and said Image generation successful, do I have to do anything else or I reboot and that’s it? (I don’t know about these things)

OK then you missed a bit off the UUID earlier, I did think it was a bit short, it helps when you post the correct information. :slight_smile:

1 Like

I would try that, yes.

Oh no! I’m sorry it was not on purpose, now I understand the characters you asked me about :man_facepalming: I didn’t realize I didn’t copy the entire line

1 Like

I rebooted but got the same error

No worries. :slight_smile:

Hey @dibyte

Somebody reported a similar issue in the thread below:

The solution would be adding vmd to the MODULES section in the /etc/mkinitcpio.conf file. Then, regenerate initramfs and reboot.

It looks like this is an ongoing issue with mkinitcpio already reported on the Arch Bug Tracker

Hope that helps!

Edit: The above procedure needs to be done under chroot.


It actually looks like the problem I have, however, I’m getting the same error or I don’t know if I’m doing something wrong:

  1. I boot Manjaro from pendrive
  2. I run sudo vim /etc/mkinitcpio.conf and then add the “vmd” module:
    MODULES=(vmd), then I save and quit.
  3. Run sudo mkinitcpio -P
  4. Reboot
  5. Get same error

Did you do a chroot for this?

If not, do a chroot and try again under the chroot

1 Like