ERROR: Device '' not found. Skipping fsck / ERROR: failed to mount '' on real root

Hi, im new to manjaro and i recently installed it on my mac mini late 2012
after a success installation and using refind, i ended up getting a boot error that is not letting me get into the OS, i have been researching about how to fix it but i didnt get a proper answer about how to fix it.

This is the error i get:

ERROR: device '' not found. Skipping fsck.
:: mounting '' on real root
mount: /new_root: no valid filesystem type specified.
:: running emergency hook [plymouth]
ERROR: Failed to mount '' on real root
You are now being dropped into an emergency shell
sh: can't access tty: job control turned off

i also tried using the

mkinitcpio -P

and during the process i get warnings about missing firmware, i have a doubt that some stuff is missing or something? but i am still unable to get into manjaro

I also tried updating the kernel (before linux66) to linux68 but also no effect.

Is there a way to fix it? or i have to do everything again?.

Edit: the only way im accessing to manjaro is through the USB live boot

Bad entries in your fstab I would guess?

i got this screen and i dont know what to do next?
im researching but not completely understanding

NAME   FSTYPE   FSVER    LABEL            UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0  squashfs 4.0                                                                  0   100% /run/miso/sfs/livefs
loop1  squashfs 4.0                                                                  0   100% /run/miso/sfs/mhwdfs
loop2  squashfs 4.0                                                                  0   100% /run/miso/sfs/desktopfs
loop3  squashfs 4.0                                                                  0   100% /run/miso/sfs/rootfs
├─sda1 vfat     FAT32    EFI              2860-11F4                                           
├─sda2 apfs                               b9af957a-67a0-4f31-b09c-3901d2f5a17c                
├─sda3 ext4     1.0      Manjaro          dd3cf909-7829-44a2-9547-147642eb95ed                
├─sda4 ext4     1.0      boot             3092444e-60e2-424c-9e44-6b2a37633b65                
└─sda5 ext4     1.0      root             8e1a6598-50f6-4003-b5e1-b777139ddb28                
sdb    iso9660  Joliet E MANJARO_KDE_2313 2024-01-13-03-10-45-00                     0   100% /run/miso/bootmnt
├─sdb1 iso9660  Joliet E MANJARO_KDE_2313 2024-01-13-03-10-45-00                              
└─sdb2 vfat     FAT12    MISO_EFI         B5B6-A7FC

the sda3 is where the OS is installed

ok so while i was navigating i found the /etc/fstab

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=8e1a6598-50f6-4003-b5e1-b777139ddb28 /              ext4    defaults,noatime 0 1
UUID=3092444e-60e2-424c-9e44-6b2a37633b65 /boot          ext4    defaults,noatime 0 2
UUID=dd3cf909-7829-44a2-9547-147642eb95ed /home          ext4    defaults,noatime 0 2

and i dont see any issues?, the only thing i dont understand is ‘‘noatime’’