Error: could not open file rslsync: Error reading fd 7

What I’m trying to install is Resilio sync, but I’ve come across an error that I’ve found no answer for.

The salient commands run are:

git clone
sudo pacman -U rslsync

The last of which failed, giving this message:

loading packages...
error: could not open file rslsync: Error reading fd 7
error: 'rslsync': cannot open package file

I’m assuming the former error caused the latter error.

Not quite.

git clone
cd rslsync
makepkg -srcif


Even if you built it successfully, that won’t work because that’s not the filename. It would be something like rslsync-2.7.2-1-x86_64.pkg.tar.zst. In my example above the makepkg -i flag installs it, so a separate step is not needed.

1 Like

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.