Error activatong XKB configuration

Hello,

Clean install of manjaro cinnamon. After adding a keyboard layout and settings layout switching key combination, on login an error message appears:

Error activatong XKB configuration
There can be various reasons for that.

If you report this situation as a bug, include the results of
xprop -root | grep XKB
gsettings get org.gnome.libgnomekbd.keyboard model
gsettings get org.gnome.libgnomekbd.keyboard layouts
gsettings get org.gnome.libgnomekbd.keyboard options

Any clues?

TIA

1 Like

I am at the same situation.
First I tried to add keyboard layout
Then I tried $ setxkbmap -layout ir to change layout. It worked but then even this command stopped working.

Hi Farhad,

I Used this:

setxkbmap -model pc105 -layout us,il -option grp:alt_shift_toggle -option numpad:microsoft

It works OK.

1 Like

Thanks

The only solution that has worked for me and persisted is by adding this command to my ~/.profile

setxkbmap -model pc105 -layout us,de -option grp:alt_shift_toggle

It seems like 00-keyboard.conf is being ignored, as both localectl commands and manual edits (Xorg/Keyboard configuration - ArchWiki) never made any change to the error.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.