Erroneous Password Rejection XFCE

I’m running xfce, kernel Was attempting to install font and got an error in KFontVIewer- restarted tried again, and KViewer Install button was grayed out. repeated. . Through Add & Remove, software found software called Font Manager from Flatpack. I downloaded but disliked right away. I removed it using the same Add Remove Software interface… Both occasions required my password.

Not long after while attempting to mv in the terminal to move one of my created folders, for whatever reason the mv command was rejected. I thought maybe sudo was required. When I entered my password it responded incorrect. I tried again thinking I had a typo but it was still rejected. On my third time, after making sure cap locks was not on, etc and very carefully entering the password ir was not only rejected- it appeared visible at the prompt. So I know I typed it correctly. I couldn’t tell if maybe i hit a button unknowingly or what but being visible shouldn’t have happened. The message was third time error. Later in a new terminal I tried 1 more time received another rejection with a message that I had entered my password wrong 1x. I attempted to run Add & Remove Software and password again failed. After reading some comments- and because my account automatically logs in I took a chance to reboot. It logged back in. I then went into Add & Remove.Software and the password was accepted. Out of fear, I haven’t tried using password in the terminal again --I need to do a backup first…

I know Flatpak isn’t necessarily supported by Manjaro but…this is such a serious problem. I read so many others with same password problem so I am only relaying this to anyone on the project who it might help. No technical advice needed at the moment.