Epson Workforce 3640 can't print shows on network - can't find driver in the AUR

Manjaro 20 - Cinnamon

I have an Epson WF 3640 on the network and it shows from Nemo as a printer.

I can’t find a driver on the AUR for the WF 3640

When I try to setup printers I get a cups error: failed to connect to the server

I’ve got everything working as I want and really don’t want to do a fresh install. I do have a home partition and could leave that alone. I have some applications that did install to the /opt and a fresh install would most likely overwrite it. I could deal with backing them up but all this work just to print???

Until I get this solved I’ll have to open Mint and use it to get my work done. Hope there are answers.

Well no answers so I reinstalled, now I have a printer. Yay!

You probably missed the renaming of the services?

1 Like

The recommended driver for this printer is Epson Inkjet Printer Driver (ESC/P-R) - Epson-WF-3640_Series

I suggest you install epson-inkjet-printer-escpr from AUR

1 Like

Was working yesterday and today I booted and now it can’t put up the printer.

I’ll give those commands a try.

I think I tried that but I’ll try it again. First I’m going to try some terminal commands that CSCS wrote.

Ok it brought back my printer now the question is what happened, why did it go away?

sudo systemctl disable --now org.cups.cupsd.socket

[sudo] password for john:
Removed /etc/systemd/system/
Failed to stop org.cups.cupsd.socket: Unit org.cups.cupsd.socket not loaded.
[john@johnmanjaro ~]$ sudo systemctl disable --now org.cups.cupsd.service
Removed /etc/systemd/system/
Failed to stop org.cups.cupsd.service: Unit org.cups.cupsd.service not loaded.
[john@johnmanjaro ~]$ sudo systemctl disable --now org.cups.cupsd.path
Removed /etc/systemd/system/
Failed to stop org.cups.cupsd.path: Unit org.cups.cupsd.path not loaded.
[john@johnmanjaro ~]$ sudo systemctl enable --now cups.service
Created symlink /etc/systemd/system/ → /usr/lib/systemd/system/cups.service.
Created symlink /etc/systemd/system/ → /usr/lib/systemd/system/cups.socket.
Created symlink /etc/systemd/system/ → /usr/lib/systemd/system/cups.path.
[john@johnmanjaro ~]$ sudo systemctl enable --now cups.socket
[john@johnmanjaro ~]$ sudo systemctl enable --now cups.path