Epson Perfection V600 drivers (part2)

This topic is an iteration of the same but closed discussion epson-perfection-v600-drivers/6072/14 and epson-perfection-v600-drivers-on-manjaro/12867 .

The question is to scan with the Epson Perfection V600 scanner using Manjaro (in my case XFCE4).

  • xsane 0.999 does not work. The scanner is not detected.
    Therefore Epson provides drivers, latest are epsonscan2 6.6.40.0-2 . There is also an equivalent AUR package named epsonscan2 .

Installing these lead to xsane detecting the right scanner hardware, but not being able to connect to it.

Failure during connecting to the hardware ‘epsonscan2:Perfection V600/etc.’ Failure during hardware I/O.

  • Using the simpler scanning application epsonscan2 lead to the same problem: It detects and apparently connects to the scanner, even opens the GUI application. But using that one (e.g. clicking on scan preview) leads to an application crash (“Scan data could not be saved.” "Console return says: “segmentation fault (core dumped) epsonscan2”)

Overall, scanning with the Epsonscan2 app works fine by installing the provided .deb in Debian-based distros. So I would guess that the issue might be regarding the Arch architecture.

If someone can confirm this or has an idea to solve this, I would be very grateful. Thank you for the interest.

Hi @Balkonsky, and welcome!

Although I don’t know how recommended this is, but I’m guessing it must at least be a bit since thee functionality is there, it would seem you are ale to install a .deb package using dpkg.

$ dpkg --help
Usage: dpkg [<option>...] <command>

Commands:
-i|--install       <.deb file name>... | -R|--recursive <directory>...
[...]

So you could, theoretically install it with:

sudo dpkg --install </path/t/deb.file>

From the terminal, where </path/t/deb.file> is, you guessed it :wink:, the path to the .deb file.

Hope this helps!

I have a Epson Perfection V550 photo - the AUR driver package is iscan-plugin-perfection-v550. I had to install with yay for it to build, for some reason. Then I use Vuescan and it works like a charm.

Thank you both, @Mirdarthos and @Pentastarch.
I tried to install with sudo dkpg --install. Certainly a good tip, though it didn’t work out, having this .deb included an ./install.sh script that can be executed directly (and which installs without issues).
Then I tried to even build from sourcecode, that went also through without issues. Yet both the issues with xsane and epsonscan2 reside.

The tip with installing the AUR package iscan-plugin-gt-x820 worked, the scanner can be used properly with (proprietary but feature-rich) VueScan application! So this is a more than viable way to make use of the scanner under Manjaro.

Thanks a lot, Manjaro community!

Nevertheless, I will further try to reach the AUR package maintainer and see if they can look into their epsonscan2 package. To ensure an opensource way to scan.

2 Likes

that will never work
(or end well, if you somehow manage to force it)

dpkg is Debian’s (and Ubuntu’s) package manager
pacman is what Arch uses (or pamac, for Manjaro)

foreign packages can be utilized - via a PKGBUILD from AUR for example
but they cannot be used directly

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.