EPSON-ET-4750 taking 40-60 minutes to print from CUPS

I was having issues with my printer, whenever I’d try to use the CUPS recommended drivers, I’d get 'Unable to copy PPD file," even though it works fine in other distros I’ve used. I later found an additional driver from the AUR. The first I tried printing something with the AUR driver, the status would say "Unable to locate printer “EPSON3621A5.local” but after 5 minutes or so it printed. Now it’s taking 40 minutes or more to print something, during that time I get the same “Unable to locate printer…” message. I can ping the printer’s IP address just fine but CUPS can’t locate my printer for some reason.

My suggestion is to completely uninstall the printer (and remove it from the printers list) and start again. It would also help to know which driver you installed from AUR.

I know it sounds silly, but my Epson WF-series wireless printer had a similar symptom. I had placed the printer in a cabinet and checked the LCD status board which showed a good WiFi connection but when I moved it closer to the Access Point, all the symptoms went away.

1 Like

I tried sending the link to the AUR page but it said that I couldn’t. Here’s the link to the driver AUR (en) - epson-inkjet-printer-escpr2

That’s definitely interesting, but I’ve tried printing on Linux Mint (as my daily driver) and Solus (on a live session) with the printer in the same location and it worked just fine. I’ll definitely try it out though

What if you print a simple text page? Does it take that long?

Yes, it’s still takes a long time.

Do you have a static IP on the printer? You can set it in the printer options (at the printer itself). Then go to the PC and check the address on the printer configuration program. I did that to mine because sometimes cups complained it couldn’t find it.

Just tried moving my printer closer, nothing seemed to change, also tried connecting my printer through LAN since I put it right next to my modem and nothing.

No luck with static IP address, still get unable to locate printer message.

I really don’t have any more ideas :man_shrugging:

Do you know of a way to use the CUPS recommended driver rather than the AUR one? Maybe that would help? I don’t think it’s something wrong with my printer, like I said in a previous comment, I’ve tried printing in other distros and it’s worked just fine without needing the AUR driver.

Other distros probably don’t even have AUR. The point is the printer should function properly with that driver, because that’s the driver EPSON delivers for Linux. The only thing I can think of is to completely uninstall everything, removing the printer from devices, and install from the beginning. You can also try to connect with USB to test if WiFi is the issue or not.

I’ve noticed that with distros that use CUPS 2.2.x, I don’t get any issues with my printer, but other distros (like Manjaro) that use CUPS 2.3.x. I assume that there’s some problem between my printer and CUPS 2.3, is there any way to downgrade the version of CUPS in Manjaro?

Yes, you can try the archlinux archive repository.

sudo pacman -U

I’m still having the same issue, it’s a real shame, I really like Manjaro but I don’t have any more ideas other than using a virtual machine for printing or installing a different distro : (

But, does it happen with cups 2.2.x also?

To answer your question, yes I was having the same issue with cups 2.2.x.

However, while I was experimenting with printing in Debian 10 in VM, where I was having similar printer issues with cups 2.2.10. I tried a connection that said Ipd://<my.printer’s.ip.address>/PASSTHRU, then I selected the recommended driver and it worked perfectly.

That gave me the idea to do the same with Manjaro, in cups 2.3.3 (or the default version Manjaro comes with) I selected the PASSTHRU connection then tried a similar driver to the one that worked in Debian. My printer was working, but, it wasn’t giving some of the options I wanted like printing on both sides of a page, so I tried the AUR driver for my printer AUR (en) - epson-inkjet-printer-escpr2 and it worked perfectly.

The strange thing is that I never saw a PASSTHRU connection whenever I added a printer in cups, all my other options started with dnssd or ipps. The only thing that changed with my printer is that it’s connected to a different computer through usb.


FWIW, I have an Epson ET-2760, which I selected and installed the usual way, and it prints promptly and perfectly.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.