EPSON Ecoprint ET-2711 cannot install properly

I bought a new Printer EPSON Ecoprint ET-2711.

Unfortunately I cannot get it to work in Manjaro.

I followed this instructions on the manjaro wiki.

It looks like the Printer is detected as the older 2710 model which is maybe not an issue:

Unfortunately I cannot select or find drivers for this model. I already tried drives for other EPSONs but the result is I can send printings to the printer but it only prints random letters on the paper instead of the document.

USB or wifi connected?

USB connected

driver should be okay since it is what Epson itself tell to be correct.
But still could be an driver or firmware issue.

What you can try is setup a driverless printer. Works almost 100% of the time but lacks some driver specific options.

If thats oke start removing the printer and turn printer off and on

Next install ipp-usb

pamac install ipp-usb

start it with
systemctl start ipp-usb
systemctl enable ipp-usb

Now add a printer en pick the driverless version

check if it works

I run the commands but in the printers I cannot select anything driveless in the printers dialog.


[sandro@sandro-pc ~]$ pamac install ipp-usb
==== AUTHENTICATING FOR org.manjaro.pamac.commit ====
Authentication is required to install, update, or remove packages
Authenticating as: Sandro Wissmann (sandro)
Synchronizing package databases…
Resolving dependencies…
Checking inter-conflicts…
To install (1):
ipp-usb 0.9.13-2 extra 1,9 MB

Total download size: 1,9 MB
Total installed size: 6,3 MB
Apply transaction ? [y/N] y
Download of ipp-usb (0.9.13-2) started
Download of ipp-usb (0.9.13-2) finished
Checking keyring… [1/1]
Checking integrity… [1/1]
Loading packages files… [1/1]
Checking file conflicts… [1/1]
Checking available disk space… [1/1]
Installing ipp-usb (0.9.13-2)… [1/1]
Running post-transaction hooks…
Reloading system manager configuration… [1/3]
Reloading device manager configuration… [2/3]
Arming ConditionNeedsUpdate… [3/3]
Transaction successfully finished.
[sandro@sandro-pc ~]$ systemctl start ipp-usb
[sandro@sandro-pc ~]$ systemctl enable ipp-usb
Created symlink /etc/systemd/system/ → /usr/lib/systemd/system/ipp-usb.service.
[sandro@sandro-pc ~]$

I also get this error:

[sandro@sandro-pc ~]$ sudo systemctl enable org.cups.cupsd.service
[sandro@sandro-pc ~]$ sudo systemctl start org.cups.cupsd.service
[sandro@sandro-pc ~]$ sudo systemctl --now enable cups
Failed to enable unit: Unit file cups.service does not exist.

Sorry I forgot something.
Just make sure you don’t have removed the printer in your setup

You also need a running avahi daemon for this.

First check if avahi in installed. If not install it.

To start and enable the daemon

sudo systemctl enable --now avahi-daemon

Oke last part we need to start and enable the browser service

sudo systemctl enable --now cups-browsed.service

Now it should work. If i am not mistaking it should even add the printer automatically if not try by hand.

should that not be systemctl enable --now org.cups.cupsd.service?

Also if you done the former two the last one is not needed.
systemctl enable --now ‘service’ enables and starts the service so there is no need to do a enable en start separately.

I could solve the problem by installing epson-inkjet-printer-escpr2 via AUR.

Then I selected a similar model which is Ecotank aswell an now the printer works.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.