Epson BX305FW won't scan

Hi I have the Epson BX305FW combined printer scanner, the printer is working fine but I can not get the scanner to work. I have Image scan (image aquisition utilities for epson) installed but can not the scanner to work I get error "Could not send command to scanner check scanner status). I have turned off my firewall and checked that the printer is connected to wifi but still no joy. Document scanner can not find any scanners either

Edit Solved

I had image scan from the official repos installed. I had to install imagescan from the official repos for the scanner to be found. Hope it helps someone else

I’ve never had any luck with Image Scan. There’s a paid, proprietary utility called VueScan that supports a bunch of network scanners, and works well.

Glad you got image scan to work, though.

1 Like

I’m still having trouble with it unfortunately. It’s now recognising my scanner which it wasn’t before but it’s recognising it as the wrong model so won’t scan. When I was on Mint there was an app called simple scan that worked really well and was free. I’ve downloaded the drivers from the epson website and will try building them myself hopefully that will fix it properly

Simple Scan is there (sudo pacman -S simple-scan), but it didn’t work for me. It did recognize my scanner, which is as far as I’ve ever gotten on Linux with my scanner with only free software.

With utushi (imagescan), it seems you have to manually configure it to see your network scanner (it picks a default IP address which is wrong in my case), but I’m not sure how to fill out all of the necessary fields in the config files.

Try vuescan-bin in the AUR. It’s proprietary, but has worked well for me. It’s one of only two bits of proprietary userspace software that I still use (not counting drivers, firmware, etc.) It’s $40 for a limited number of upgrades, or $90 for lifetime upgrades. I bought the $40 package about a year ago, and still haven’t run out of upgrades. They have standalone packages you can download from the website as well: hamrick dot com

(I’m not related to them in any way. I don’t know that it’s a good company or otherwise, I just know that it has worked for me so far). Also, I believe it’s try-before-you-buy.