Enabling virtual keyboard on Login Screen

Hi everyone, how to set up the screen keyboard when logging into the manjaro system.

When I remember correctly there is a option called accessibility in GDM. There you should enable it with the mouse.

And I have this option selected. It is not on the login screen. It is visible only after logging into the system. I do not know if it is important, but I have a laptop with an additional connected screen.

So you selected “Screen Keyboard” on the login screen (GDM) at right top? There is a drop-down menu. I just tested it… works.

GDM and gnome-session are 2 separate things. You need to enable it in both.

Yes, I know that the accessibility options are in the upper right corner of the login screen because I had it in another Zorin OS distribution but it is not here.

Ok well… that is strange… I connected another monitor now… even rebooted … still viewable and works in GDM. Sorry, but I cannot reproduce your problem.

Maybe Monitors have different resolutions and the upper right corner is just hidden, so not on the screen?

Maybe it is worth mentioning that I am on unstable branch. Could be possible that an issue was fixed recently.

Thank you for trying to help :wink:

I found a solution to my problem. No accessibility on the login screen. I know I need to activate the Accessibility menu for the GDM login screen. This is described in https://wiki.archlinux.org. Could someone describe to me step by step how to do this procedure.

Hi, I’ve tried the procedure described in archwiki to no avail. They don’t appear to make a difference here, i.e. `org.gnome.desktop.interface toolkit-accessibility ‘boolean’’ does not toggle the on-screen-keyboard. Perhaps the solution is hidden deeper in gdm doc.

Have you reconfirmed above that the accessibility icon does not appear in gdm, when you boot your machine without the additional screen?

edit: I’ve found the gconf key that enables the on-screen keyboard per default. It’s not the one in the wiki, but org.gnome.desktop.a11y.applications screen-keyboard-enabled:

$ sudo machinectl shell gdm@ /bin/bash
$ gsettings set org.gnome.desktop.a11y.applications screen-keyboard-enabled true
$ exit
$ sudo systemctl restart gdm

activates it for my system.

So I have confirmed that the availability icon does not appear in gdm after booting the computer.

I assume that is after trying the steps I described above.

Have you tried without your additional monitor? Does the regular top-right icon next to accessibility appear? Do you use X11 or Wayland (default)?

I can confirm that this indeed does not work, unless we login that we cannot because onscreen keyboard is missing.

Archwiki instructions are outdated.