Enable boot messages

I currently try to enabler the boot messages. The reason for that is, that I want to see what happen on boot and if there are any errors. I had removed quiet and splash from GRUB_CMDLINE_LINUX_DEFAULT and I had ran sudo update-grub. But now my PC shows only a black screen until the login menu appears. Here is my current /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="apparmor=1 security=apparmor udev.log_priority=30"

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment this option to enable os-prober execution in the grub-mkconfig command

Have a look into this explanation:

Sorry if I have expressed myself in a misleading way but I mean the boot messages that are shown in this picture for example:

The bootsplash is thart thing I don’t want.

I think you need to enable rd.log environment variable for your mkinitcpio; I just checked man mkinitcpio and the following looks like what you might be after:

Enables logging of early userspace messages. If specified, the optional parameter describes where this information is logged. Multiple options can
be OR’d together using the pipe (|) character. Messages are always logged to the console unless the quiet parameter is passed. If the optional
parameter is not specified, kmsg|console is assumed. If rd.log is not present on the kernel command line, no logging will take place.

Sorry for keep you waiting, but I had some other things to do. The Arch Wiki says to mkinitcpio: “mkinitcpio is a Bash script used to create an initial ramdisk environment. From the mkinitcpio(8) man page”. I did not use any ramdisk. I shutodwn my computer and I do not suspend.

Isn’t this what you want? Uncomment the line.

Unfortunately uncommenting this line doesn’t change anything.

It surprisingly works now. I had to replug my HDMI cable. After that it works for some reason.

I can’ t get it done. And I can’t just replug my HDMI cable cause I’m on a laptop. Is there a way I can get those beautiful green [OK] messages on startup,

get rid of “udev.log_priority=30” it should be 3 and not 30 even if you want it to be so.

i’m asssuming you didnt play with mkintcipio.conf, if you did you need the hooks to start with “base udev”

something like;

HOOKS=(base udev autodetect modconf block filesystems keyboard fsck)

First of all, create a separate topic instead of hijacking the old one.
Second, provide the output of cat /proc/cmdline in that new thread of yours.