Enable AMD FreeSync


I want to enable AMD FreeSync but I have the following problems.
When I create the file “/etc/X11/xorg.conf.d/20-amdgpu.conf” and place the following lines in there:

Section “OutputClass”
Identifier “AMD”
MatchDriver “amdgpu”
Driver “amdgpu”
Option “VariableRefresh” “true”

Then, after a reboot and running this command “systool -vm amdgpu | grep free”
The output is the following:

freesync_video = “0”

How can I enable FreeSync?
Thanks for your help :slight_smile:

Is your screen capable of VRR?

xrandr --props | less

There should be vrr_capable: 1 be printed.

No, but at windows, my it’s working fine with FreeSync, my monitor supports FreeSync.

If your screen is not capable of VRR aka Freesync, then I doubt it works on Windows. Even if you activate it in the settings, it will not work until the screen can work with it.

Please add:

 inxi -Gazy 

And maybe the decoded edid file:

pamac build edid-decode-git
find -L /sys/class/drm/ -maxdepth 2 -type f -iname "*edid" -exec edid-decode "{}" \; 2>/dev/null

Also check if your monitor is in that list: https://www.amd.com/en/products/freesync-monitors

I’m using GNOME with Wayland, after installing mutter-vrr it’s working fine.

I have one more general question about the Linux topic.
I have jaa now installed mother-vrr via yay (aur), if I update my manjaro to 23.0 or to a new version, does that change again?

:man_facepalming: Alright. At least you figured it out yourself that wayland is not xorg.

mutter-vrr replaces a system package mutter. So yes, you could get problems on updates.

What’s so bad to use GNOME with Wayland?
When I go back to “mutter” it will update automaticially on MKanjaro updates?

There is nothing bad, and that was not what I was saying.

Yes in general. Just be careful with AUR, especially when it replaces system packages.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.