Emacs: tab bar is not showing when tool bar is disabled

Hello everyone,

I am using Manjaro i3wm for the last 3 years. It is my main OS (and it is fantastic!). :slight_smile:

However, recently I am having some issues with emacs, which I want to share with you.

From terminal I run emacs -Q.
Within emacs M-x tool-bar-mode; this will disable tool bar.
Then M-x tab-bar-mode; this will enable tab bar but the tab bar is not visible.
Finally, M-x C-q; now the tab bar is visible.

The expected behavior is that the tab bar will become visible immediately after M-x tab-bar-mode.

First I thought this is emacs’ problem but later I checked in Ubuntu and Ubuntu has the same version of emacs (28.2) but does not have the problem. I also filed a bug report in emacs mailing list. They also confirmed that Ubuntu does not have this problem. So, probably you guys can help me.

There is also a related problem.

Suppose my init.el is just the following

 '(tab-bar-mode t)
 '(tool-bar-mode nil))

Now if I open emacs then I get https://ibb.co/qxT3LX6 (I don’t have the permission to embed image and link, so I put the link to a code block. Sorry for that. Please edit this post if needed.). As you can see, instead of taking the entire window, the editable area is a small part of it. :frowning:

If you know any work around, please share.

OS: Manjaro 22.0.0 Sikaris
Kernel: x86_64 Linux 5.19.14-1-MANJARO
WM: i3wm
GNU Emacs 28.2 (build 1, x86_64-pc-linux-gnu, GTK+ Version 3.24.34, cairo version 1.17.6)
of 2022-09-12

Just to report, I have tried EndeavourOS and Fedora 36. Both have same problems. So I don’t think this is Manjaro specific issue. I will wait for an upstream update.

@MicrosoftXiaoice I don’t know what solution you are taking about. Could you please explain?