Emacs client won't start new frame

Hi everyone,

I’m new to manjaro linux and i’m a emacs user. I use it with emacsclient to speed up startup time. So i run the command emacs --daemon. Once that’s done, i use emacsclient -c to open a new frame each time i want to use emacs.

Unfortunately, it doesn’t open up a new GUI frame, but opens the console version of emacs (which is fine, but i want the gui version in order to have gui fonctionalities like clipboard).

Do you know what could be happening ?


Have you checked that emacs or emacsclient commands are not aliased with the -nw / --tty flags just in case ?

I personally launch the emacs daemon through systemd as suggested in the “Emacs Server” info page:

If your operating system uses ‘systemd’ to manage startup, you can
automatically start Emacs in daemon mode when you login using the
supplied “systemd unit file”. To activate this:
systemctl --user enable emacs
(If your Emacs was installed into a non-standard location, you may
need to copy the ‘emacs.service’ file to a standard directory such
as ~/.config/systemd/user/.)

If this doesn’t work, maybe try using the -d/--display switch when invoking emacs as a daemon.


Thank you very much for your answer. I was about to make an long answer explaining how i investigated using your advices. But then i thought, what if i tried

emacs -Q --daemon

After that, emacsclient -c works properly. It means it’s my emacs configuration which is faulty. I “just” have to find the correct line to edit now…