Electrical pops from speakers with 5.10 kernel

My speakers started making an electrical noise with every sound when I changed to 5.10 a few days ago. I have since switched back to 5.9, which fixes the problem.

I’m not sure what the correct term is, but it’s the sound a speaker sometimes makes when it is on, and the amplifier (in this case a computer sound adaptor) is turned on. I’ve noticed it previously on startup.

With kernel 5.10, every sound is proceed by that pop, unless there has been continued sound in the meantime, like music playing. It seems like the sound adaptor is turned off when not in use, which causes that particular sound when it is turned on to produce a sound.

Does anyone have the same experience? How and where should I report this for further investigation and potential fix?

Is the problem you are experiencing like when there is no sound playing (silence in a movie) the speaker makes a pop or slight delay when the sound comes back on? My expensive speaker system does the same. I fixed it by sending a 1hz inaudible signal at all times.

Try opening this link in a browser and see if the problem goes away:

If so, we can fix it using a systemd service.

‘USB go pop’ is a common problem, and you are

It seems like the sound adaptor is turned off when not in use

Short pops or noise can occur when a USB device is suspended by a PulseAudio module (module-suspend-on-idle)

To test for this, unload the PulseAudio module

pacmd unload-module module-suspend-on-idle 

the module is only unloaded temporarily with that command
If removing the module works for you, PulseAudio configuration can be changed to disable the module permanently

sudo sed -Ei '/load-module module-suspend*/s/^/#/' /etc/pulse/default.pa

This adds a comment tag ‘#’ to the start of the line to prevent the module being loaded

It’s not USB speakers. I should have mentioned that. 3.5 mm jack.

No, it’s not like that. Whenever there’s silence, nothing playing, it’s fine. When discord/hexchat/whatever makes a sound, the speakers go pop+sound. If the sound continues, there’s no popping. When there’s been silent for another few seconds, the next sound played (from any source) triggers pop+sound.

I don’t know how to describe the sound better than the sound we all know from speakers when the amp is turned on.

I have posted a link to your post for another user that may need it
but that topic might find a different way to resolve the issue you describe

That’s exactly the problem I was trying to describe. Did the tone generator solve the problem?

My issue was resolved years ago, on Linux at least. I cannot find a solution on Windows except for having that web page open in the background.

If your internet is down the webpage might not work

There should be software for a sine wave generator or signal generator that is simpler than I can think of:

Sox works on Windows - Using Sox to Synthesize Sound

Audacity has a tone generator (Generate > Tone… )

Or just record the Linux tone to an audio file to play in a loop on Windows

He didn’t mention anything about a problem with the internet, so your post is moot. I provided a link to the simplest method of generating a tone possible. If you know of an easier method, easier than opening a link, then please post it!

Sox and Audacity are unable to run as a systemd like service on windows. They need to be opened and configured, hence not a windows solution.

I was using Sox and Audacity on XP long before systemd existed. They were just a couple of ideas that I know would work. There should be simpler options for the other OS more suited to the abilities of their current users

I already posted another way to generate a tone to the other topic (see the link on your post) but I first suggested using PulseAudio module-sine on the old forum about 2 years ago

pactl load-module module-sine frequency=1

If that works, the module can be added to PulseAudio module list in home folder:

cat <<EOT > ~/.config/pulse/default.pa
.include etc/pulse/default.pa
load-module module-sine frequency=1

maybe this helps:

run the script with ./the-name-of-file having terminal in the same directory where you created the empty file, don’t forget to grant execution permissions to the file before executing it.

@babywhale suspect that it is new to linux, of course it is inside manjaro, I just verified it in your profile, if you need graphic help or more detailed steps to execute the script, let me know by answering here below.