Elden Ring not lauching

Elden ring is not launching.
The Game starts to a black screen and shuts down.
It was working well until i had a rx6600 as soon as i changed my GPU to Intel Arc a77016gb LE it does not launch. I am very new to Linux and know nothing of the command line. Is there any way to fix this or should i wait until there driver update which will fix this.

Yesterday I had similar issue. I restarted Steam and it worked :wink:

I tried everything still it is not working.

I would say, you need to install a video driver for your new card, since ATI Radeon and Intel are not compatible.
From a quick search on the net, it says, you should have at least Kernel 6.x, 6.1 should be save.
An easy way to install the driver would be in a terminal with

for non-free drivers

sudo mhwd -a pci nonfree 0300 

or for free (open code) driver

 sudo mhwd -a pci free 0300 

Something may be up with it, I wasn’t able to get past the initialize screen. Cyberpunk works great atm. I’ve got no time to debug right now, but usually protonDB will have a hotfix out when a major game stops working. Play another game for a few days. :smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.