ELAN Touchpad not working on Manjaro or Ubuntu

I recently bought a new Lenovo Laptop and the touchpad is working fine in Windows 10, nut want to switch over to Linux.

For the time I have dual booted with Manjaro and even tried Ubuntu once, but the touchpad is not working in both of them.

I am only able to use an external mouse and no response form the Elan touchpad. I saw others having the same problem but none of the solutions I found online at other forums helped.

I am adding the output of xinput, please tell if I should add anything else as well.

My kernel version: 5.11.6-1-MANJARO

⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ Logitech USB Optical Mouse              	id=10	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Power Button                            	id=8	[slave  keyboard (3)]
    ↳ Integrated Camera: Integrated C         	id=9	[slave  keyboard (3)]
    ↳ Ideapad extra buttons                   	id=11	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=12	[slave  keyboard (3)]

Thanks in advance.

Which lenovo model are you using?

Edit: you could try the woraround on page 18 of this guide which worked on debian

However, strange, because this should not be a problem with newer drivers implemented in newer linux kernels like with manjaro…


The Lenovo Model I am using is: 82C500U7IN (Model Number). Lenovo V15 Model

I will try the workaround and will reply if it works.

Thanks for your reply.


I tried the workaround mentioned in the pdf but the touchpad is stil not working.