ELAN Touch pad not detected at all in Manjaro

My ELAN Touch pad is not detected by the system. It used to work fine in the pre-configured Windows 10 that it came with but it is not working on any Linux distro now.

The same issue happens with Ubuntu as well. It also does not seem to work on a fresh install of Windows 10 too.

I have tried all the solutions available online regarding this topic but none of them seem to work.

I have attached the output of xinput list.

Please tell if I should attach some other results.


Kernel Version: 5.12.9-1
xinput list

⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ Logitech USB Optical Mouse              	id=10	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Power Button                            	id=8	[slave  keyboard (3)]
    ↳ Integrated Camera: Integrated C         	id=9	[slave  keyboard (3)]
    ↳ Ideapad extra buttons                   	id=11	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=12	[slave  keyboard (3)]

What’s the version of kernel you currently running? Have you tried other kernels?

I am currently running 5.12.9-1

And yes I have tried other versions, but it still didn’t work.

Output of inxi -Fazy please.
What kernels have you tried so far?
Output of journalctl --no-pager --no-hostname -b -p 3 after suspend and wake please.

inxi _Fazy

  Kernel: 5.12.9-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.12-x86_64 
  root=UUID=ecf2b4ea-9114-4fb3-94b3-5c2fadce967e rw quiet splash i8042.nopnp 
  apparmor=1 security=apparmor 
  resume=UUID=a320a7b5-31ce-4462-8ede-f5f87ae81dc4 udev.log_priority=3 
  Desktop: GNOME 3.38.4 tk: GTK 3.24.29 wm: gnome-shell dm: GDM 40.0 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: LENOVO product: 82C5 v: Lenovo V15-IIL serial: <filter> 
  Chassis: type: 10 v: Lenovo V15-IIL serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: SDK0Q55722 WIN serial: <filter> 
  UEFI: LENOVO v: DKCN49WW date: 10/26/2020 
  ID-1: BAT0 charge: 28.8 Wh (98.3%) condition: 29.3/30.0 Wh (97.8%) 
  volts: 8.6 min: 7.5 model: SMP L16M2PB1 type: Li-poly serial: <filter> 
  status: Charging cycles: 196 
  Info: Quad Core model: Intel Core i5-1035G1 bits: 64 type: MT MCP 
  arch: Ice Lake family: 6 model-id: 7E (126) stepping: 5 microcode: A0 cache: 
  L2: 6 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 19048 
  Speed: 1300 MHz min/max: 400/3600 MHz Core speeds (MHz): 1: 1300 2: 1300 
  3: 1296 4: 1301 5: 1300 6: 1301 7: 1300 8: 1297 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Iris Plus Graphics G1 vendor: Lenovo driver: i915 v: kernel 
  bus-ID: 00:02.0 chip-ID: 8086:8a56 class-ID: 0300 
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo bus-ID: 1-5:3 
  chip-ID: 04f2:b624 class-ID: 0e02 serial: <filter> 
  Display: x11 server: X.Org 1.20.11 compositor: gnome-shell driver: 
  loaded: modesetting alternate: fbdev,intel,vesa display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 dpi: 142 size: 344x193mm (13.5x7.6") 
  diag: 394mm (15.5") 
  OpenGL: renderer: Mesa Intel UHD Graphics (ICL GT1) v: 4.6 Mesa 21.1.2 
  direct render: Yes 
  Device-1: Intel Smart Sound Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel alternate: snd_sof_pci_intel_icl bus-ID: 00:1f.3 
  chip-ID: 8086:34c8 class-ID: 0403 
  Sound Server-1: ALSA v: k5.12.9-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.30 running: no 
  Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter 
  vendor: Lenovo driver: rtw_8822ce v: N/A modules: rtw88_8822ce port: 4000 
  bus-ID: 01:00.0 chip-ID: 10ec:c82f class-ID: 0280 
  IF: wlp1s0 state: up mac: <filter> 
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 
  bus-ID: 1-10:4 chip-ID: 0bda:c02f class-ID: e001 serial: <filter> 
  Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: enabled,running 
  rfk-block: hardware: no software: yes address: see --recommends 
  Local Storage: total: 238.47 GiB used: 49.97 GiB (21.0%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital 
  model: PC SN530 SDBPMPZ-256G-1101 size: 238.47 GiB block-size: 
  physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD 
  serial: <filter> rev: 21160001 scheme: GPT 
  ID-1: / raw-size: 229.37 GiB size: 224.71 GiB (97.97%) 
  used: 49.97 GiB (22.2%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 296 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p3 maj-min: 259:3 
  System Temperatures: cpu: 51.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 271 Uptime: 1m wakeups: 1 Memory: 7.57 GiB used: 2.62 GiB (34.6%) 
  Init: systemd v: 248 tool: systemctl Compilers: gcc: 11.1.0 Packages: 1398 
  pacman: 1392 lib: 324 flatpak: 0 snap: 6 Shell: Zsh v: 5.8 running-in: guake 
  inxi: 3.3.04 

journalctl --no-pager --no-hostname -b -p 3

Jun 30 10:09:34 kernel: x86/cpu: SGX disabled by BIOS
Jun 30 10:09:34 systemd[1]: Failed to start Setup Virtual Console.
Jun 30 10:09:34 systemd-vconsole-setup[247]: /usr/bin/loadkeys failed with exit status 1.
Jun 30 10:09:34 kernel: platform idma64.0: failed to claim resource 0: [mem 0x00000800-0x00000fff]
Jun 30 10:09:34 kernel: platform idma64.0: failed to claim resource 0: [mem 0x00000800-0x00000fff]
Jun 30 10:09:40 kernel: irq 9: nobody cared (try booting with the "irqpoll" option)
Jun 30 10:09:40 kernel: handlers:
Jun 30 10:09:40 kernel: [<000000004d18a57b>] acpi_irq
Jun 30 10:09:40 kernel: Disabling IRQ #9
Jun 30 10:09:40 bluetoothd[717]: Failed to set mode: Blocked through rfkill (0x12)
Jun 30 10:09:44 gdm-password][1198]: gkr-pam: unable to locate daemon control file
Jun 30 10:09:47 systemd[1208]: Failed to start Application launched by gnome-session-binary.
Jun 30 10:13:01 bluetoothd[717]: Failed to set mode: Blocked through rfkill (0x12)

I have used the 5.10, 5.11 kernels and 4.14 as well just to check if it worked.