Egpu slowdowns Manjaro gnome when set to primary gpu

I bought a razer core x so I could use my sapphire rx580 gpu with my thinkpad T480. On manjaro gnome it was automatically detected by gnome settings and I gave it full access and then rebooted. After rebooting the epgu was recognized by both gnome settings and when I ran neofetch but if I try to use for gaming on steam it still uses the cpu only. After that setback , I use both PRIME as specified in this arch wiki article PRIME - ArchWiki (
more specifically this command $ DRI_PRIME=1 glxinfo | grep “OpenGL renderer” ) and I tried using the AUR package egpu-switcher-git to set the primary gpu to the epgu. In both cases when I reboot my laptop the entire de becomes extremely slow and sluggish and only way to fix it is to set the gpu back to the Intel one. My understanding is that not using an external monitor cause a performance hit but that doesn’t really explain whats happening here and I’m just wondering if there something here in the process I’m missing?

1 Like

Thats just to check its working. (output of glxinfo with DRI_PRIME= 0 or 1)
It shouldnt have any lasting affect on anything.
You launch something with that command, ex in a steam games launch options:
DRI_PRIME=1 %command%

Anyways … I guess you are reporting it does work. good.

I dont know anything about this software … but its simple enough to set what is called ‘reverse prime’ if you just want the gpus loaded the other way around (this new one as default, the embedded one as secondary). Of course note that in general this is not used because of power draw and other issues - usually you want to use the integrated device for things like the desktop, and the heavy dGPU for mining, games, 3D, etc selectively.

In any case you shouldnt need extra utilities… see:
https://wiki.archlinux.org/index.php/PRIME#Reverse_PRIME

yeah thankfully it been pretty easy to fix anything I’ve done to my machine with one very slow terminal command :sweat_smile: so for the first option I would just type in something DRI_PRIME=1 steam-manjaro? if that doesn’t work I’ll look into reverse PRIME then

Yes and No.

  • The usual way is using PRIME
  • By default this means iGPU always, and dGPU when it is called
  • PRIME is used with command DRI_PRIME
  • steam is special - recommendations are not to start steam itself with variables, but instead to use game launch options individually and put in exactly DRI_PRIME=1 %command%
    (assuming no other options)
  • regardless of whether you have steam or steam-manjaro installed it should be started using steam

https://wiki.manjaro.org/index.php?title=Configure_Graphics_Cards#Dual_GPU

(PS - if you do it the ‘normal’ prime way it also means everything is kept pretty normal … if you unplug this secondary device and walk to the cafe and boot up you wont notice a thing except that DRI_PRIME=1 doesnt work to initialize the absent device)

okay sorry for the delay I was testing it out on a steam game and like you said it seems to work once I set the launch command to DRI_PRIME=1 %command%

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.