Editing Boot Options for IOMMU support

Hi ppl, hopefully this is fairly simple.
I’m following Oracle’s instructions to enable PCi-passthrough in VirtualBox. Manjaro Linux is my host. I’ve enabled the IOMMU in the EFI, and dmesg | grep IOMMU returns the following:
[ 0.802843] pci 0000:00:00.2: AMD-Vi: IOMMU performance counters supported
[ 0.810763] pci 0000:00:00.2: AMD-Vi: Found IOMMU cap 0x40
[ 0.811802] perf/amd_iommu: Detected AMD IOMMU #0 (2 banks, 4 counters/bank).
[ 0.844318] AMD-Vi: AMD IOMMUv2 driver by Joerg Roedel jroedel@suse.de
[ 4.249136] snd_emu10k1 0000:05:00.0: non-passthrough IOMMU detected, widening DMA allocations
well that last line doesn’t seem promising, but the instructions wanted me to make another check anyway so I continue with that. it says to search for DMAR and PCI-DMA in the kernel boot log, to check that the kernel “recognizes and uses” the IOMMU unit. dmesg | grep DMAR and dmesg | grep PCI-DMA both return nothing, cementing the concerns.

so now the issue: the instructions say the boot option “intel_iommu=on” may be necessary. I have a couple questions about that:

  1. Is /etc/default/grub the correct file to edit for this?
  2. Do I add the line anywhere in the file?
  3. is “intel_iommu=on” still the correct option if I’m using an AMD motherboard?

I’m running kernel 5.4.89-1 if that’s relevant.

Thank you!

That’s a kernel parameter. This page will have the answer for you.

Don’t believe so.

You can get better help on this topic at r/VFIO. It’s a subreddit dedicated to GPU passthrough with a lot of helpful people. They also have a wiki.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.