Edifier w820nb doesn't work well on manjaro gnome

Currently I’m using a headphone Edifier w820nb, the main problem is that I can’t user the headphone with both microfone and phone at the same time. What happens these days is that what comes out of my microphone to the people on the call with me is actually what I’m hearing.

in the sound configuration with High Fidelity Playback (AD2P sink ) selected the sound output for the ppl in call is what i’m hearing, a music, sound sytem etc), that is, my microphone dont works.

And with Hands Free Unit(HFP) just makes my microphone work, but I can’t hear nothing

some informations about my system:

  Kernel: 5.15.32-1-MANJARO arch: x86_64 bits: 64 Desktop: GNOME v: 41.5
    Distro: Manjaro Linux
  Type: Desktop Mobo: ASRock model: A320M-HD serial: <superuser required>
    UEFI-[Legacy]: American Megatrends v: P6.07 date: 11/14/2019
  Info: quad core model: AMD Ryzen 3 2200G with Radeon Vega Graphics bits: 64
    type: MCP cache: L2: 2 MiB
  Speed (MHz): avg: 1991 min/max: 1600/3500 cores: 1: 2854 2: 1588 3: 1589
    4: 1933
  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Mobile Series]
    driver: amdgpu v: kernel
  Display: x11 server: X.org v: with: Xwayland v: 22.1.1 driver:
    X: loaded: amdgpu unloaded: modesetting,radeon gpu: amdgpu resolution:
    1: 1366x768~60Hz 2: 1920x1080~60Hz
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
  Device-2: AMD Family 17h/19h HD Audio driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.15.32-1-MANJARO running: yes
  Sound Server-2: PulseAudio v: 15.0 running: yes
  Sound Server-3: PipeWire v: 0.3.49 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: br-1f0f3477a393 state: down mac: <filter>
  IF-ID-2: br-834713ce6bcd state: up speed: 10000 Mbps duplex: unknown
    mac: <filter>
  IF-ID-3: br-9f4b4c101667 state: up speed: 10000 Mbps duplex: unknown
    mac: <filter>
  IF-ID-4: docker0 state: down mac: <filter>
  IF-ID-5: veth3fafc1b state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-6: veth52aecad state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-7: veth536706a state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-8: veth651a287 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-9: veth6c039c3 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-10: veth780fe02 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-11: veth95690a0 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-12: vethd0bd799 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-13: vethde7cfb5 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb
  Report: bt-adapter ID: hci0 state: up address: <filter>
  Local Storage: total: 715.41 GiB used: 83.44 GiB (11.7%)
  ID-1: /dev/nvme0n1 vendor: Seagate model: XPG SPECTRIX S40G
    size: 476.94 GiB
  ID-2: /dev/sda model: SSD 256GB size: 238.47 GiB
  ID-1: / size: 468.38 GiB used: 83.44 GiB (17.8%) fs: ext4
    dev: /dev/nvme0n1p1
  Alert: No swap data was found.
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 49.0 C
  Fan Speeds (RPM): N/A
  Processes: 389 Uptime: 3d 13h 0m Memory: 13.58 GiB used: 11.08 GiB (81.6%)
  Shell: Zsh inxi: 3.3.15

If someone wanna any information, tell me.

EDIT: Both microphone and phone works well if I plug It on pc with the USB-C cable instead of bluetooth

I always suggest to either use one or another but not both, in spite the fact that is not a must and many consider it normal to have them both running. Have you tried to go with just one? For example pipewire …

pamac install manjaro-pipewire

Hi @bogdancovaciu , I’ve installed manjaro-pipewire and removed pulseaudio.
Now I have 5 options in my output configuration

  • headset Head Unit (HSP/HFP, codec mSBC)
  • High fidelity Playback (A2DP Sink)
  • High fidelity Playback (A2DP Sink, codec SBC-XQ )
  • High fidelity Playback (A2DP Sink, codec SBC)
  • High fidelity Playback (A2DP Sink, codec AAC )

With the first, both microphone and phone are working, but I can’t use noisecanceling mode when click on the button on my headset, and the sound quality is very poor.

With the others, the sound is ok, but the microphone is still not working.

I only can suggest to go trough this Bluetooth headset - ArchWiki
I’m not aware on how noise cancellation is supposed to work via the headphone. No experience with that, except the noise-suppression-for-voice from AUR or noisetorch or alsa-rnnoise