ECG software Checkme Browser Pro on WINE

I have an ECG monitor “Pulsebit Ex” whose data is read by a software named “Checkme Browser Pro” via USB. The software is only available for Windows, but runs fine with WINE, except that it does not find the device. Is there a way to make the device accessable for WINE? There is a hidraw and a hiddev device on Linux, when I plug in the device. I tried sudo chmod a+rw without success.

Output from lsusb -v:

Bus 001 Device 015: ID c25a:330e ViATOM Checkme Lite
Couldn't open device, some information will be missing
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass          239 Miscellaneous Device
  bDeviceSubClass         2 [unknown]
  bDeviceProtocol         1 Interface Association
  bMaxPacketSize0        64
  idVendor           0xc25a ViATOM
  idProduct          0x330e Checkme Lite
  bcdDevice            0.01
  iManufacturer           1 ViATOM
  iProduct                2 Checkme Lite
  iSerial                 3 0001A0000000
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength       0x0022
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0x80
      (Bus Powered)
    MaxPower              100mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         3 Human Interface Device
      bInterfaceSubClass      0 [unknown]
      bInterfaceProtocol      0 
      iInterface              5 
        HID Device Descriptor:
          bLength                 9
          bDescriptorType        33
          bcdHID               1.00
          bCountryCode            0 Not supported
          bNumDescriptors         1
          bDescriptorType        34 Report
          wDescriptorLength      33
          Report Descriptors: 
            ** UNAVAILABLE **
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval               1

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Hi @stoffel,

According to this:

Wine is not a emulator (hence the name). There isnt a pass-through since wine isnt a VM but just translates the windows calls into unix ones…So any hope you have must rely on linux kernel support for your hardware or a proper VM with a passthrough.

So your best bet would be a VM with USB passthrough, something like QEMU:

I know it’s not what you wanted to hear, but I nevertheless hope it helps.

Wine runs as your user - from your user account.

As a normal user you might not be allowed to access the needed devices.

The Arch wiki here:

Users and groups - ArchWiki

says (I understand it that way) that you may need to be a member of the uucp group
(and/or the tty group perhaps)

Perhaps then, the user who runs wine gets the proper permissions.

It’s just a thought. Speculation.

@Mirdarthos: I guess, VirtualBox has no proper pass through, right? I have USB 2.0 enabled in VirtualBox, but there is no device to share. And the software does not detect the device, nor is it shown in the Windows device manager.
@Nachlese: I’m already member of group uucp because I use the tool ubpm to read my blood pressure monitor. Also adding my user to group tty doesn’t work, and the device seems not to be mapped as a TTY device; at least I don’t see it in /dev as ttyX.

wrong :wink:
you can pass through certain devices or the whole port where you connect the device
and this has always worked for me
but some time ago I decided against VirtualBox in favor of VirtManager
kvm based
but it is essentially the same
pass a device or the whole port

re wine and group membership and stuff …
it was just an idea - it might have helped
based upon how wine is run (as a user process)

@Nachlese: Wow, it works indeed. I added my user to group vboxusers and a device filter in VirtualBox, and now I can access the device from Windows in the VM. Until now, I used the software on my Windows Mini PC and copied the data to my main Linux PC. So using a VM is definitely the better solution. Thanks!

1 Like