DVD player no longer playing DVDs


This is happening on both my laptop and desktop but I load a dvd in and the player spins up but nothing loads or is mounted. VLC doesn’t see the disc at all.

Any ideas please?



Is the disc player seen by the system ?

1 Like

… one way to check that is:
open a terminal and run:
journalctl -f
in it
then watch the output as you open and close the tray with the dvd loaded

1 Like

Or dmesg.

as a suggestion:
sudo dmesg -w
sudo dmesg -W
(-w and -W is shorthand options for --follow and --follow-new)
with the same effect as
journalctl -f (journalctl --follow):
not everything is printed, but only new messages as they appear - a “live ticker” of the latest messages
That way it is easy to spot what is happening with just one command

for the dmesg command, sudo is needed

Nothing happens.

At the moment I don’t think so. It was seen a few days ago and now nothing. I ran cdrecord dev=/dev/sr0 -checkdrive

Are these two different drives or just one that you tried at two different computers?

If none of these commands (journalctl -f or sudo dmesg -w) gives any reaction or feedback to your connecting the drive or opening and closing the tray with a dvd in it, then the system can’t see the drive.

Bad cable or drive broken …


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.