Duplicate fake files on desktop not selectable

In the picture - there’s 3 files on the desktop, but only the selected file is the real one.
As i move this file, the other 2 move with it at set spacing.
If i delete the file, those other two remain.

What’s happening? :smiley:

This is on my second monitor. If i move the real file to the main monitor, the 2 duplicats to to the top of the screen. I

Can you show us the output:

$ stat -f -c '%T' /home
$ ls -al ~/Desktop

Yes, the first one is btrfs, and the second one is this:

total 44
drwxr-xr-x  1 veprovina veprovina  380 sij   8 17:16  .
drwx--x---+ 1 veprovina veprovina  812 sij   8 18:17  ..
-rw-r--r--  1 veprovina veprovina 3404 sij   5 15:07 'AMD info terminal.txt'
-rw-r--r--  1 veprovina veprovina   50 pro  28 12:06  .directory
-rw-r--r--  1 veprovina veprovina 3790 sij   5 15:08 'IOMMU groups.txt'
-rwxr-xr-x  1 veprovina veprovina  230 sij   5 15:07  IOMMU.sh
-rwxr-xr-x  1 veprovina veprovina   72 sij   8 02:29 'looking-glass-client fullscreen'
-rw-r--r--  1 veprovina veprovina   29 sij   5 22:37 'Text File.txt'
-rw-r--r--  1 veprovina veprovina 8998 sij   7 18:00 'VM XML backup.txt'
-rwxr-xr-x  1 veprovina veprovina  440 sij   6 23:07 'VtM Bloodlines Unofficial Patch.desktop'
-rw-r--r--  1 veprovina veprovina 1337 sij   6 23:07 'VtM Bloodlines Unofficial Patch.lnk'

There’s only one looking glass client file in the list, yet 3 are shown on the desktop.

And after locking the screen while i was AFK and going back in. A 3rd fake file appeared!
Lol, what? They’re evolving! :smiley:

Here’s the video of it in action:

They move with the original file, but you can’t select them.

Do other files have the same issue on Desktop?

Can you test:

  1. Create a new KDE user.
  2. Logout and switch to another user.
  3. Copy this file to another KDE Desktop, check if it has the same issue?

Ok, i’m getting scared now:

I’m not gonna do another user, i’ll try logging out.

The file is just a bash script i did chmod +x on to make it executable and does cd to looking glass folder and ./looking.glass -F, that’s it.

I made an empty file, then put that script in. Did i have to add the .sh at the end? It works though, so not sure if that made it go haywire…

I created the same executable file. but I can not reproduce this issue on KDE Wayland and Btrfs. :man_shrugging:

1 Like

Thanks for trying.

This was what was in it:


cd /home/veprovina/looking-glass
./looking-glass-client -F

I mean, simple enough…
I emptied it, deleted all of it inside, and now i’m gonna restart the computer and see what happens.

Click the right button of mouse on Desktop → Desktop Folder Settings → Icons →

Arrangement: “Left to Right” and “Align left” , Unlock in place

That’s already set up this way.

I copied this text, but I have no issue.

1 Like

I didn’t either until i rebooted… But i doubt the bash script is the problem.
For instance, it doesn’t open display settings all of a sudden when right clicking desktop.

I’m gonna restart, see what happenns. Be right back.

Oh wow, i didn’t even restart, and since i deleted the contents of the file, the duplicates disappeared.

Still can’t open configure display settings…

Upon restarting - the files are still gone, and i can open display settings.

I think i’m gonna start looking glass from the terminal manually from now on. :rofl:

Thanks for the help and troubleshooting this with me!

So it was something with the script i guess. I deleted the file. :stuck_out_tongue:

These duplicates of the file appeared after Manjaro and KDE update without rebooting?

Yes, i think. They first appeared after resuming from sleep i believe, and exponentially duplicated each time resuming from lock screen. After i removed the bash script from the file, they all disappeared (and the file changed the icon to an empty file one).
After the restart, i could access the display settings too. Probably unrelated, but when you told me to align, i also tried to see the display settings but could not get it to open. So a restart fixed that.
So… Not sure what happened, why the script caused the file to make fake duplicates… Maybe cause i didn’t make it an .sh script? Just empty file with that in it?
Still, i can’t see how a simple cd directory and ./file -argument command would do this. :smiley: